Skip to Content
author's profile photo Former Member
Former Member

SolMan Charm: wbch and customizing TR not always automatically released

Dear solman experts,

In Charm, when users save a status linked to the background action "release_all" in order to release their transport requests, the transports are not always released.

I know this could happen with ToC and also with TR (mostly for workbench), but this is happening to lots of customizing transports.

I tested it with some small configuration (like for instance a TR with roles in it), the release works fine.

So the configuration of solman seems ok.

Does anyone have already faced the same issue and has an idea on what to do in order to avoid this issue?

Thanks for your help,

Kr,

Alice

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    Posted on Jun 21, 2010 at 01:12 PM

    Hi Alice,

    I don t have any access to Solman that has ChaRM running on it but i can still try helping you ...

    I know that Solman before asking for a TR release through an RFC Call DOES CHECK in internal data base tables logs of Transport Request.

    Your message "/TMWFLOW/TRANSPORT_N643" is displayed in at least one case (one that i could fine on my SOlman with no ChaRM) in line 272 of program /TMWFLOW/SCMA_TRORDER_RELEASE.

    This ABAP program is called by schedule managet (tasklist) when you launch a release of Transport Requests and do a couple of checks before launching actual release (like checking for critical objects, status ofTransport Requests...)

    In order to check status request, the program checks table /tmwflow/trordhc and THIS IS PROBABLY WHERE THE PROBLEM IS COMMING FROM. In this table I guess you have status 'released' for TR that are not actually released.

    Could u double check that there is a gab between info stored in this table and status of your transport requests in Dev BRD

    Regards,

    Khalil

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 21, 2010 at 08:48 AM

    Hello Alice,

    I don t know if that's your case but sometimes people attempt to release Transport Requests (Wb or Cust) w/o checking that taks of those transport requests are actually released (that has to be done in DEV)! There is a standard condition in SPRO that you can run when user status reached that does that check before even let people trying to release tr.

    This might be a reason why you can't release. Another reason could be that you re using SDMJ ticket AND the maintenance cycle that your SDMJ ticket is assigned to is at a maintenance phase that does nt allow releasing tranport requests (for ex: build witouht release).

    Could you try giving us more details or logs of Solman when you try releasing. You can get those logs from ticket and normally more detailed ones from maintenance cycle tasklist (tr: /n/tmwflow/proj)

    Hope this helps

    Regards

    Khalil

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 21, 2010 at 12:43 PM

    Hello Khalil,

    In the maintenance cycle, the ongoing phase is "development with release" so it is ok.

    Also, all tasks have already been released as one of the previous status/action triggered the creation of a ToC (and for that the check of all released tasks is performed). So we have like two testing cycle (a first one with ToC where all tasks are already released) and if it is ok you can then set a status which triggers the "release_all" action to release the orginial transport requests.

    What is really strange is that in the tasklist, the release request activity is correctly launched but has an error " /TMWFLOW/TRANSPORT_N643" which says that :

    - Diagnosis --> The request BRDK922172 has already been released (but it is not the case)

    - System Response --> The system does not allow you to create a transport of copies. (but it is not the action concerned here "the activity on which I receive this error is "release_all""

    - Procedure--> It is not usually necessary to create a transport of copies for a request that has already been released.Perhaps you entered an incorrect request, in which case you have to enter a different one.

    I do not get what is this error message about. And what is really strange is that for some transport requests the release works and for other not (but more and more are not working)

    Have you an idea?

    Thanks a lot for your help,

    Alice

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 06, 2010 at 09:41 AM

    Hello Alice,

    can you let us know if your question is answered... or if someone can help ?

    Regards

    Khalil

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Khalil,

      Unfortunately the problem still persists... we do not know why for some transports it is working fine and for others it is not.

      We are applying an additional check step on our process (each time the status is changed, we have to check if the release was done correcty or not, and if not, we do it ourselves manually).

      It is not a big blocking issue, if I find the reason for such a behavior one day, I will let you know;

      Your answers were useful, thanks a lot for the time you took;

      Kr,

      Alice

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.