Skip to Content
avatar image
Former Member

Unable to start SAP

Hi All,

I am quite new to SAP, and need your help. I am running SAP with DB6 in Solaris 10 platfrom. I have recently encounter an issue where I could not start the SAP services after bringing it down. Each time when I execute command "startsap all", I saw this error:

Database activated

/usr/sap/DEV/SYS/exe/run/startdb: test: unknown operator OFF

DB startup failed

Anyone here can help me out?

Thanks in advance.

rgds,

Ronny

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Jun 20, 2010 at 11:15 AM

    Hi,

    Did you checked the errors in the db2dump directory?, especially check db2diag.log file.

    also try to start database from the db2 prompt. #db2>db2start.

    Regards,

    Sam

    Add comment
    10|10000 characters needed characters exceeded

    • > Informational tokens are "DB2 v9.5.0.0", "special_18161", "SUN6495_18161", Fix Pack "0".

      > DATA #2 : System Info, 1592 bytes

      I would

      - install the latest fixpack, I'm not sure if 9.5 without any fixpack was supported.

      and

      > System: SunOS TSDT5ERP 5.10 Generic_142900-05 sun4v

      Check if your system configuration is set according to

      Note 724713 - parameter settings for Solaris 10

      Markus

  • avatar image
    Former Member
    Jun 20, 2010 at 05:56 PM

    Dear Paul,

    On behalf of Ronny, I can explain to you our situation as he's my colleague.

    You are correct on the error:

    ZRC=0x81360012=-2127167470=SQLZ_RC_CMERR, SQLT_SQLJC

    "External Comm error"

    It does occur ONLY when the db2 startup with startsap all.

    It doesn't occur when we do manually 'db2start' command.

    Do you have any clue on this?

    Thanks.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 20, 2010 at 06:08 PM

    Entry for sapstart.log:

    -


    SAP-R/3-Startup Program Rel 700 V1.8 (2003/04/24)

    -


    Starting at 2010/06/21 00:54:10

    Startup Profile: "/usr/sap/DEV/SYS/profile/START_DVEBMGS01_TSDT5ERP"

    Setup Environment Variables

    -


    (800) SETENV LD_LIBRARY_PATH=/usr/sap/DEV/DVEBMGS01/exe:/usr/sap/DEV/DVEBMGS01/exe:/usr/sap/DEV/SYS/exe/run

    (800) SETENV SHLIB_PATH=/usr/sap/DEV/DVEBMGS01/exe:

    (800) SETENV LIBPATH=/usr/sap/DEV/DVEBMGS01/exe:

    (800) SETENV DB2_CLI_DRIVER_INSTALL_PATH=/usr/sap/DEV/DVEBMGS01/exe/db6_clidriver

    Update local Kernel Files

    -


    (801) Local: /usr/sap/DEV/SYS/exe/run/sapcpe name=DEV

    (800) system(/usr/sap/DEV/SYS/exe/run/sapcpe name=DEV) returns 1

    (800) Return-Code 1 in Local-Kernel-Update. See sapcpe.log.

    Execute Pre-Startup Commands

    -


    (805) Local: /usr/sap/DEV/SYS/exe/run/sapcpe pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP

    (800) system(/usr/sap/DEV/SYS/exe/run/sapcpe pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP) returns 4

    (815) Local: /usr/sap/DEV/SYS/exe/run/sapcpe pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP copy_links list:/usr/sap/DEV/SYS/global/db6/SUNOS_64/clidriver.lst source:/usr/sap/DEV/SYS/global/db6/SUNOS_64

    (819) Local: /usr/sap/DEV/SYS/exe/run/sapcpe pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP list:/usr/sap/DEV/SYS/global/db6/jdbc/jdbcdriver.lst source:/usr/sap/DEV/SYS/global/db6/jdbc

    (823) Local: /usr/sap/DEV/DVEBMGS01/exe/sapmscsa pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP -n

    (825) Local: rm -f ms.sapDEV_DVEBMGS01

    (827) Local: ln -s -f /usr/sap/DEV/DVEBMGS01/exe/msg_server ms.sapDEV_DVEBMGS01

    (829) Local: rm -f dw.sapDEV_DVEBMGS01

    (831) Local: ln -s -f /usr/sap/DEV/DVEBMGS01/exe/disp+work dw.sapDEV_DVEBMGS01

    (833) Local: rm -f co.sapDEV_DVEBMGS01

    (835) Local: ln -s -f /usr/sap/DEV/DVEBMGS01/exe/rslgcoll co.sapDEV_DVEBMGS01

    (837) Local: rm -f se.sapDEV_DVEBMGS01

    (839) Local: ln -s -f /usr/sap/DEV/DVEBMGS01/exe/rslgsend se.sapDEV_DVEBMGS01

    (841) Local: rm -f ig.sapDEV_DVEBMGS01

    (843) Local: ln -s -f /usr/sap/DEV/DVEBMGS01/exe/igswd_mt ig.sapDEV_DVEBMGS01

    Starting Programs

    -


    (847) New Child Process created.

    (847) Starting: local ms.sapDEV_DVEBMGS01 pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP

    (847) Starting local Command:

    Command: ms.sapDEV_DVEBMGS01

    pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP

    (848) Starting: local dw.sapDEV_DVEBMGS01 pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP

    (848) New Child Process created.

    (848) Starting local Command:

    Command: dw.sapDEV_DVEBMGS01

    pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP

    (849) Starting: local co.sapDEV_DVEBMGS01 pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP -F

    (849) New Child Process created.

    (849) Starting local Command:

    Command: co.sapDEV_DVEBMGS01

    pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP

    -F

    (850) Starting: local se.sapDEV_DVEBMGS01 pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP -F

    (850) New Child Process created.

    (850) Starting local Command:

    Command: se.sapDEV_DVEBMGS01

    pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP

    -F

    (851) Starting: local ig.sapDEV_DVEBMGS01 -mode=profile pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP

    (851) New Child Process created.

    (851) Starting local Command:

    Command: ig.sapDEV_DVEBMGS01

    -mode=profile

    pf=/usr/sap/DEV/SYS/profile/DEV_DVEBMGS01_TSDT5ERP

    (800) Waiting for Child Processes to terminate.

    (800) **** 2010/06/21 00:56:14 Child 848 terminated with Status 0 . ****

    (848) **** 2010/06/21 00:56:14 No RestartProgram command for program 1 ****

    (800) **** 2010/06/21 01:18:58 Caught Signal to Stop all Programs. ****

    (800) Parent Shutdown at 2010/06/21 01:19:00

    (800) Stop Child Process: 851

    (800) Wait 300 sec for Process 851 terminating...

    (800) Stop Child Process: 850

    (800) Wait 300 sec for Process 850 terminating...

    (800) Stop Child Process: 849

    (800) Wait 300 sec for Process 849 terminating...

    (800) Stop Child Process: 847

    (800) Wait 300 sec for Process 847 terminating...

    Execute Post-Shutdown Commands

    -


    (800) Exiting with Return-Code 0. (Ok)

    -


    Entry for dev_rfc.trc:

    >TS> Mon Jun 21 01:18:23 2010

    T:6 Error in program 'igsmux_m': ======> Connect to SAP gateway failed

    Connect_PM TPNAME=IGS.DEV, GWHOST=TSDT5ERP, GWSERV=3301

    LOCATION CPIC (TCP/IP) on local host

    ERROR partner '172.18.35.75:3301' not reached

    TIME Mon Jun 21 01:18:23 201

    RELEASE 700

    COMPONENT NI (network interface)

    VERSION 38

    RC -10

    MODULE nixxi.cpp

    LINE 2513

    DETAIL NiPConnect

    SYSTEM CALL connect

    ERRNO 146

    ERRNO TEXT Connection refused

    COUNTER 52

    -


    Entry for CPICTRC852:

    Mon Jun 21 01:18:23 2010

    ***LOG Q0I=> NiPConnect: connect (146: Connection refused) [nixxi.cpp 2513]

    • ERROR => NiPConnect: SiConnect failed for hdl 3 / sock 14

    (SI_ECONN_REFUSE/146; I4; ST; 172.18.35.75:3301) [nixxi.cpp 2513]

    • ERROR => GwIConnect: GwConnect to TSDT5ERP / 3301 failed (rc=NIECONN_REFUSED) [gwxx_mt.c 296]

    ***LOG S0T=> GwIConnect, GwConnect (-0010) [gwxx_mt.c 297]

    ***LOG S0R=> GwIConnect, GwConnect () [gwxx_mt.c 299]

    ***LOG S0S=> GwIConnect, GwConnect (3301) [gwxx_mt.c 301]

    ***LOG S90=> SAP_CMREGTP2, GwIConnect ( 236) [r3cpic_mt.c 9638]

    *****************************************************************************

    *

    • LOCATION CPIC (TCP/IP) on local host

    • ERROR partner '172.18.35.75:3301' not reached

    *

    • TIME Mon Jun 21 01:18:23 2010

    • RELEASE 700

    • COMPONENT NI (network interface)

    • VERSION 38

    • RC -10

    • MODULE nixxi.cpp

    • LINE 2513

    • DETAIL NiPConnect

    • SYSTEM CALL connect

    • ERRNO 146

    • ERRNO TEXT Connection refused

    • COUNTER 52

    *

    *****************************************************************************

    -


    db2licm -l

    Product name: "DB2 Enterprise Server Edition"

    License type: "CPU Option"

    Expiry date: "Permanent"

    Product identifier: "db2ese"

    Version information: "9.5"

    Features:

    DB2 Database Partitioning: "Licensed"

    DB2 Performance Optimization ESE: "Licensed"

    DB2 Storage Optimization: "Licensed"

    DB2 Advanced Access Control: "Not licensed"

    DB2 Geodetic Data Management: "Not licensed"

    DB2 pureXML ESE: "Not licensed"

    IBM Homogeneous Federation ESE: "Not licensed"

    IBM Homogeneous Replication ESE: "Not licensed"

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      Run R3trans -d as <sid>adm and check the trans.log file, you will be able to identify the issue from there.

      Regards,

      Sam

  • avatar image
    Former Member
    Jun 21, 2010 at 04:22 AM

    We've run R3trans -d

    This is R3trans version 6.14 (release 700 - 03.11.09 - 14:15:00).

    unicode enabled version

    R3trans finished (0000).

    In the log, everything looks fine:

    4 ETW000 ================== STEP 1 =====================

    4 ETW000 date&time : 21.06.2010 - 12:14:41

    4 ETW000 function : CONNECT

    4 ETW000 buffersync : YES

    4 ETW000 clients : default

    4 ETW000 l.s.m. : VECTOR

    4 ETW000 commit : 100000

    4 ETW000 table cache : dynamic

    4 ETW000

    4 ETW000 [dev trc ,00000] Disconnecting from ALL connections: 6837 0.006837

    4 ETW000 [dev trc ,00000] Disconnected from 'DEV' 20733 0.027570

    4 ETW000 [dev trc ,00000] Disconnected: con_hdl=0 ; appl_hdl=14; appl_id="172.18.35.75.34488.100621041441"

    4 ETW000 221 0.027791

    4 ETW000 [dev trc ,00000] Disconnected from connection 0 206 0.027997

    4 ETW000 [dev trc ,00000] statistics db_con_commit (com_total=1, com_tx=1) 131 0.028128

    4 ETW000 [dev trc ,00000] statistics db_con_rollback (roll_total=0, roll_tx=0) 130 0.028258

    4 ETW000 Disconnected from database.

    4 ETW000 End of Transport (0000).

    4 ETW000 date&time: 21.06.2010 - 12:14:41

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Have you checked that the ports used by your SAP system are not yet in use by another application?

      Also please check the logfiles in /usr/sap/SID/DVBEMGS/work for the work processes as well as the dispatcher (dev_w0 and dev_disp).

  • avatar image
    Former Member
    Jun 22, 2010 at 09:11 AM

    Hello.

    have you ever checked the os kernel parameter via db2osconf command? Use man db2osconf to find out the correct syntax fpr you and then you get informations about the suggested values.

    Regards

    Olaf

    Add comment
    10|10000 characters needed characters exceeded