Skip to Content
avatar image
Former Member

XI 3.1 SSO .NET InfoView displays service account as logged on user

XI 3.1 SP2 on Windows Server 2008 R2 is configured for SSO, Java works fine but .NET displays service account as logged on user. In IIS 7.0 Windows auth. is enabled and anonymous auth. disabled.

Any ideas why this is happening? I have even copied web.config files from the servers that are functioning fine for .NET SSO. However I must mention that I had to remove IIS and add it again since I was getting service not available. After adding IIS (7), I had to manually add BOu2019s applications.

Also applicationHost.config file contains:

<location path="Default Web Site/InfoViewApp">

<system.webServer>

<security>

<authentication>

<windowsAuthentication enabled="true" useKernelMode="true" useAppPoolCredentials="true" />

<anonymousAuthentication enabled="false" />

</authentication>

</security>

</system.webServer>

</location>

Edited by: Amir Eskandari on Jun 18, 2010 8:50 PM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jun 19, 2010 at 11:56 AM

    To note the product is not tested with .net and java SSO installed on the same server. The admin guide specifically mentions this as not supported.

    That being said it can be made to work fine but isn't documented. So that brings up the question what doc(s) did you use to setup java SSO and .net SSO? Once I know that I can guestimate what additional steps you may need to perform.

    Regards,

    Tim

    Add comment
    10|10000 characters needed characters exceeded

    • Yep, I was the one that gave that suggestion on identity impersonate. I'm not sure why your other server is even working without that setting (technically it should be needed) There seems to be something strange at play, this is not an issue that is being reported by other customers and we haven't been able to reproduce in house (to prove it's a bug yet)

      Regards,

      Tim