Skip to Content
0
Former Member
Jun 18, 2010 at 09:44 AM

MaxDB backup problem through Data protector

158 Views

When I start the Online MaxDB database backup through Data Protector GUI the backup fails with error as below,

Normal] From: BSM@ttcsap10 "MAXDB_Online" Time: 6/17/10 4:30:49 AM

OB2BAR application on "ttcmaxdr" successfully started.

[Normal] From: OB2BAR_SAPDBBAR@ttcmaxdr "MAX" Time: 06/17/10 04:30:50

Executing the dbmcli command: `user_logon'.

[Normal] From: OB2BAR_SAPDBBAR@ttcmaxdr "MAX" Time: 06/17/10 04:30:50

Executing the dbmcli command: `dbm_configset -raw set_variable_1 OB2OPTS=""'.

[Normal] From: OB2BAR_SAPDBBAR@ttcmaxdr "MAX" Time: 06/17/10 04:30:50

Executing the dbmcli command: `dbm_configset -raw set_variable_2 OB2APPNAME=MAX'.

[Normal] From: OB2BAR_SAPDBBAR@ttcmaxdr "MAX" Time: 06/17/10 04:30:50

Executing the dbmcli command: `dbm_configset -raw set_variable_3 OB2BARHOSTNAME=ttcmaxdr'.

[Normal] From: OB2BAR_SAPDBBAR@ttcmaxdr "MAX" Time: 06/17/10 04:30:50

Executing the dbmcli command: `dbm_configset -raw set_variable_4 TimeoutWaitFiles=30'.

[Normal] From: OB2BAR_SAPDBBAR@ttcmaxdr "MAX" Time: 06/17/10 04:30:51

Executing the dbmcli command: `dbm_configset -raw BSI_ENV /var/opt/omni/tmp/MAX.bsi_env'.

[Normal] From: OB2BAR_SAPDBBAR@ttcmaxdr "MAX" Time: 06/17/10 04:30:51

Executing the dbmcli command: `medium_put BACKDP-Data[2]/1 /var/opt/omni/tmp/MAX.BACKDP-Data[2].1 PIPE DATA 0 8'.

[Normal] From: OB2BAR_SAPDBBAR@ttcmaxdr "MAX" Time: 06/17/10 04:30:51

Executing the dbmcli command: `medium_put BACKDP-Data[2]/2 /var/opt/omni/tmp/MAX.BACKDP-Data[2].2 PIPE DATA 0 8'.

[Normal] From: OB2BAR_SAPDBBAR@ttcmaxdr "MAX" Time: 06/17/10 04:30:51

Executing the dbmcli command: `util_connect'.

[Normal] From: OB2BAR_SAPDBBAR@ttcmaxdr "MAX" Time: 06/17/10 04:30:51

Executing the dbmcli command: `backup_start BACKDP-Data[2] DATA'.

[Critical] From: OB2BAR_SAPDBBAR@ttcmaxdr "MAX" Time: 06/17/10 04:31:45

Error: SAPDB responded with:

-24988,ERR_SQL: SQL error

-903,Host file I/O error

3,Data backup failed

17,Servertask Info: because Error in backup task occured

10,Job 2 (Backup / Restore Medium Task) [executing] WaitingT170 Result=3700

6,Error in backup task occured, Error code 3700 "hostfile_error"

1,Backupmedium #1 (/var/opt/omni/tmp/MAX.BACKDP-Data[2].1) Wrong file type

6,Backup error occured, Error code 3700 "hostfile_error"

17,Servertask Info: because Error in backup task occured

10,Job 1 (Backup / Restore Medium Task) [executing] WaitingT170 Result=3700

6,Error in backup task occured, Error code 3700 "hostfile_error"

.

[Normal] From: OB2BAR_SAPDBBAR@ttcmaxdr "MAX" Time: 06/17/10 04:31:45

Executing the dbmcli command: `exit'.

[Normal] From: BSM@ttcsap10 "MAXDB_Online" Time: 6/17/10 4:31:46 AM

OB2BAR application on "ttcmaxdr" disconnected.

[Critical] From: BSM@ttcsap10 "MAXDB_Online" Time: 6/17/10 4:31:46 AM

None of the Disk Agents completed successfully.

Session has failed.

[Normal] From: BSM@ttcsap10 "MAXDB_Online" Time: 6/17/10 4:31:46 AM

Backup Statistics:

Session Queuing Time (hours) 0.00

-


Completed Disk Agents ........ 0

Failed Disk Agents ........... 0

Aborted Disk Agents .......... 0

-


Disk Agents Total ........... 0

========================================

Completed Media Agents ....... 0

Failed Media Agents .......... 0

Aborted Media Agents ......... 0

-


Media Agents Total .......... 0

========================================

Mbytes Total ................. 0 MB

Used Media Total ............. 0

Disk Agent Errors Total ...... 0

But I have noticed the error is because of this line as below,

Executing the dbmcli command: `medium_put BACKDP-Data[2]/1 /var/opt/omni/tmp/MAX.BACKDP-Data[2].1 PIPE DATA 0 8'.

Actually it should execute the dbmcli command as

medium_put BACKDP-Data[2]/1 /var/opt/omni/tmp/MAX.BACKDP-Data[2].1 PIPE DATA 0 8 NO NO \" \" "BACK"

But I donu2019t know where to make changes so that when I start the backup through DP GUI it should use backup tool as u201CBACKu201D

But same DP backup specification is working through MaxDB Database Manager GUI.

Any solution appreciatedu2026

Thanks,

Subba