Skip to Content
author's profile photo Former Member
Former Member

Incorrect message type in IDOC for Purchase order change

Hi Gurus.

Please advise on below.

We have several purchase orders that are configured to trigger IDOC upon change. But accidentally, someone has deactiveted the automatic proposal of EDI message type for these Purchase orders which resulted to not transmitting purchase order change documents automatically.

As a workaround, we have proposed to create EDI message manually during Purchase order change. But upon checking in tcode WE09, message type is ORDERS which is PO create instead if ORDCHG for purchase order change.

Please kindly advice on why it is behaving like this for purchase orders with EDI message previously deactivated.

Thanks in advance.

Acel.

To simulate.

Create PO. go to messages, select EDI message then deactivate permanently. Save PO. Release PO if needed. Change PO. go to messages, EDI is not automatically proposed. create EDI message mamanually. Save PO. Release PO id needed. check tcode WE09, for PO create, no IDOC since it was deactivated permanently. For PO change, IDOC was triggered but with incorrect message type ORDERS instead of ORDCHG.

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 18, 2010 at 09:33 AM

    Hi Acel,

    You will need to check the settings in transaction WE20 - You will be using a Partner Profile to determine the outbound message, either for each vendor or a generic one.

    on the outbound parameters, you will need to ensure that ORDCHG is set up as a message type. If not, add it, ensuring that you use the message ORDCHG, the basic type (or extension) that you are using, usually ORDERS05 and make sure that in message control, you have process code ME02 set up. This should enable the correct message type to be determined.

    Regards,

    Rob

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 08, 2010 at 04:35 PM

    Acel

    Have you tried the suggestion by Bob? Have you check the configs on MN06 also?

    The configs which define the message conditions depends on WE20 and MN04 ,MN05 e MN06.

    Regards

    Eduardo

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.