Skip to Content
0
Former Member
Jun 15, 2010 at 12:53 PM

SRM 7.0: no service agent when creating service request or service order

30 Views

Hi Experts,

I'd like to use service orders items in SRM 7.0, that is, request external staff directly through a PO. We are not using SUS. The purchaser or purch. assistant should be able to create an item of type 'Service Order'. So far, I am able to create such an item and to select a supplier from the list, but I can't get the system to display any service agent.

I replicated the vendor from the backend system.

I set the bidder flag in the business partner and maintained a (backend) product category for this bidder.

I set the allow surrogate bidding flag (don't know whether this is necessary)

I included the vendor into a supplier list for the relevant product category

All this is necessary in order for the vendor to show up as a possible source of supply when creating the service order item.

Now,

I additionally created a contact person for the vendor (through the Web GUI)

I set the flags contact person and service agent

I did the same but this time linking an SU01 user with the contact person. I tried assigning several roles to this user, including, but not limited to, /SAPSRM/SUS_SERVICE_AGENT.

I even tried setting the SRM system as a EBP_SUS system in the landscape configuration (I first tried with LOCAL).

Still no service agent would show up when clicking on 'Add/Remove Service Agent'

Does anybody know what I'm missing, doing wrong or incorrectly assuming?

Thanks

t7