Skip to Content

No Data to Retrieve in WebI when changing prompts

We are on SAP 4.2 SP3, and I have a user who's created their own WebI report. Previously, this report had a hard-coded date range of >= 1/1/2016, and returned multiple pages of records. He modified the report to use prompts for the date, and since then, the report gives him "No data to retrieve in Query 1" when he tries to run it, regardless of which dates he uses. Many of us were able to replicate his issue on different PCs, with different security. Some of us were able to modify the report and get it to run; others were not.

The report is built on top of a universe, and we use SQL 2016 DB. I can run the SQL generated by the report and it returns data. We've checked user security, and find nothing out of the norm. I'm stumped. Any ideas?

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Posted on Jan 24, 2019 at 09:01 PM

    Can you check the Query Properties of the query returning no data? Did Max rows retrieved get checked with a value of "0"?

    Noel


    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 06, 2019 at 09:32 PM

    Max rows retrieved is set at 5000. We've also received a ticket for another user having the same problem, using different universes.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 07, 2019 at 12:18 PM

    have you tried with setting up the Locales and time zones settings in BI lanuch Pad->Preferences?

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 07, 2019 at 05:11 PM

    We have Locales and time zones set to local for all users.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.