Skip to Content
avatar image
Former Member

Java part of system doesn't start during SP stack deployment

Hi,

We refreshed the development system (dual stack on Windows2003/Oracle10 platform) by backup/restore of the production system (not controlled by sapinst... in the future we will review the procedure...). The ABAP part didn't had any problem, but the Java part didn't start due to bootstrap problems.

We resolved these problems and finally the Java part started correctly as well.

Then we started an application of Support Packages (stack 21). No problem with the ABAP part. The JSPM and the IGS updates were also successful. But when JSPM wanted to restart the Java part in safe mode, this didn't succeed.

In the work directory we found the cause: there is a safe mode lock by the former instance ID !

We tried to manually change the safe mode through Config Tool, but JSPM still wants to put the Java part in safe mode after restart.

We checked parameter lockOwnerClusterId in Configurations -> jms_provider -> DEFAULT, but this parameter is set to the new instance ID...

Any idea ?

Thanks in advance,

Christophe

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • May 31, 2010 at 10:04 AM

    Hello Christophe,

    As I understand it you have something like:

    Instance [ID<new instance id>] will run in [safe] mode, performing action

    [UPGRADE]

    Safe mode lock is imposed by instance [ID<old instance id>] - local instance will

    be disabled.

    Can you please try to adjust the providerID (instance id) in the config tool and then repeat the phase?

    Regards,

    Paul

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 31, 2010 at 10:19 AM

    Hi Paul,

    Thansk for your reply.

    That's exactly the problem.

    But the instance_ID is already the new one in the Config Tool (same for dispatcher_ID and server_ID). What do you mean by providerID ? I don't find this term via the Search button.

    Kind regards,

    Christophe

    Add comment
    10|10000 characters needed characters exceeded

  • May 31, 2010 at 11:10 PM

    Hi Christophe,

    I think the java is in safe mode to begin with, please bring the java to normal mode manually before you start updating SP stack.

    Set system in NORMAL mode manually by following below procedure

    1. Stop manually the JSPM process.

    2. Start the Config Tool script file from the /usr/sap/<SID>/<Central instance name>/j2ee/configtool/ directory.

    3. From the menu choose File -> Safe Mode. A dialog box appears.

    4. Choose Nofrom the Safe Mode Enabled drop-down list.

    5. Choose OK.

    6. Save the settings and confirm all the messages that are displayed.

    7. Restart the J2EE Engine

    Also check SDM/JSPM logs & defaul trace, paste critical messages here, we can give further suggestions.

    P.S. Note the given path for config tool is for unix installation.

    Regards

    Prashanth

    Add comment
    10|10000 characters needed characters exceeded