Skip to Content

Error appiot.attributeAuthFail in SAP IoT Application Enablement

Hello erveryone,

I am trying to connect my thing with the device, after configuring everything, i get the following error. appiotattributeauthfail.png

Meanwhile in the Data Ingestion Error Log, i get no error data-ingestion-error-log.png

anyone has any suggestion.

Thanks & Regards

Youssef Namil

appiotattributeauthfail.png

data-ingestion-error-log.png

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Jan 23 at 04:36 PM

    Looks like you might be missing some roles in your role collection - the error messages seems to come from creating the mapping, not from ingestion.

    Ingestion error log shows content only if you connection between iot service and iot ae has been setup via a ticket - see the getting started documentation for iot service.

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 25 at 09:12 AM

    Hi,

    for one you might be better of using the new meta-model when you create a new thing type. Then you would go for the Thing_Engineer_Odata role when using the new Odata meta-model. Only with the Odata thing modeler and apis yo can make use of the flexible mapping and also all upcoming new improvements. Since end of January all features work around odata thing modeles end-to-end - also the web ide.

    Secondly in both cases other then the functional scope you also have to assign your role collection to the capabilities for thing, business partner and person. So you might be ok from a functional scope to creat a thing but additionally you have to setup the instance-based authorization such that you are allowed to create or delete things.

    Regards, Marcus

    Add comment
    10|10000 characters needed characters exceeded