Skip to Content
avatar image
Former Member

ITS parameters for 7.01 with BI, portal, PI and SCM connection

I have been trying to find a list of production like parameters setting for ITS like CPIC connection and gw parameters like gw/max_overflow_size, CPIC_MAX_CONV etc etc.

We have a large number of connection into the gateway and want to make sure it is sized accordingly.

I checked not 316877 however it is only relevant for WAS 6.20.

Thanks

Weyland Yutani

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    May 25, 2010 at 05:03 PM

    Hi Weyland,

    This is more a Netweaver-related question rather than an ITS-related one.

    You can increase the profile parameter gw/max_sys. This parameter specifies the max. number of clients connected at a time. From the documentation there is no specific maximum mentioned:

    Limitations for database systems: None

    Limitations for operating systems: None

    However, if you increase the setting of gw/max_sys to a higher value you should also increase the parameter gw/max_conn with the same value.

    You need also review the timeout and keepalive parameters - gw/cpic_timeout and gw/keepalive. These parameters are used to make sure that the connections do not remain connected for too long but also do not get disconnected too quickly.

    gw/cpic_timeout

    Determines the maximum wait time during connection setup. The wait time must not exceed the interval defined by the parameter (in seconds). Otherwise the connection is terminated with a timeout.

    gw/keepalive:

    Specifies the maximum time period (in seconds) before the system checks, using a ping, whether the partner is still alive when there is no data transfer across a CPI-C connection.

    You can go to the gateway monitor smgw, use GOTO -> show parameter, mark an entry and press the F1 button to get an explanation of the parameter. This will tell you what the dafault values are and give you a better explanation.

    Try increasing the gw/max_sys and gw/max_conn with the same value, also please review the other above mentioned parameters.

    You can also review SAP note 314530 - Number of RFC/CPIC connections for external client

    Then ensure that the environment variable CPIC_MAX_CONV is set to an appropriately high level (2000) on ALL servers in this landscape.

    I hope this information helps.

    All the best,

    Cristiano

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 27, 2010 at 03:29 PM

    Thanks for the information. I do have additional question?

    Where do I set this variable:

    "Then ensure that the environment variable CPIC_MAX_CONV is set to an appropriately high level (2000) on ALL servers in this landscape."

    I run unix so do I set it in .sapenv_host.sh and csh scripts?

    thanks

    Weyland Yutani

    Add comment
    10|10000 characters needed characters exceeded

  • May 27, 2010 at 04:11 PM

    Hi Weyland,

    Yes, updating the scripts should do the trick.

    All the best,

    Cristiano

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 27, 2010 at 09:33 PM

    Thanks for the information. I do have additional question?

    Where do I set this variable:

    "Then ensure that the environment variable CPIC_MAX_CONV is set to an appropriately high level (2000) on ALL servers in this landscape."

    I run unix so do I set it in .sapenv_host.sh and csh scripts?

    thanks

    Weyland Yutani

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 01, 2010 at 02:10 PM

    How do I do the following?

    Set the env variable CPIC_MAX_CONV to 5000 in the .login profile file located in the home folder of <sid>adm.

    I have tried everything and still get 100 max conversation error from Loadrunner scripts

    Thanks

    Weyland Yutani

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Weyland,

      You need to be sure that you have set the CPIC_MAX_CONV in all servers of your system landscape.

      You can also reboot the server after setting the env parameter to ensure it is properly set.

      Best regards,

      Cristiano

  • avatar image
    Former Member
    Nov 16, 2010 at 10:29 PM

    Didn't mark as answered automatically

    Add comment
    10|10000 characters needed characters exceeded