Skip to Content
avatar image
Former Member

WorkFlow Contract Change significant is not triggering

Hello Team,

When ever user changes Contract is not triggering the Significant Workflow but it is in active mode:

significantly.jpg

in SWEL it is not showing any events.I have checked in Table swetypv.jpg. Please help me out to fix it.

Regards,

abdul gaffar .

significantly.jpg (30.2 kB)
swetypv.jpg (19.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    Dec 06, 2016 at 02:15 PM

    Hi Abdul,

    You said

    "Thanks for your valuable feedback.

    Got access to check events, just surprised to see events:

    BUS2012 CHANGED 05.12.2016 09:00:39 WS91100009 SWW_WI_CREATE_VIA_EVENT

    but actually event should be "BUS2014-->SIGNIFICANTLYCHANGED"

    Please help me out to fix it."

    I think you need to resolve any confusion about whether you are working on BUS2012 or BUS2014. BUS2012 is a Purchase ORDER, and BUS2014 is a Purchase CONTRACT. These are two different business objects - although they both do have the SignificantlyChanged event. Please determine which one you need to work on.

    Sue


    Add comment
    10|10000 characters needed characters exceeded

  • Nov 30, 2016 at 04:48 PM

    These screen shots don't do much to help us to help you. Perhaps you should show a sample of the actual Event Log? a screen shot of the Workflow Technical Log? Do you know all your background jobs are running as expected?

    Good Luck,

    Sue

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 02, 2016 at 03:21 PM

    I suspect your problem lies with your binding on step 179 - if you look carefully the system is telling you that. Please check your bindings!

    https://answers.sap.com/storage/attachments/9326-technical-details-error-log.jpg

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks for your valuable feedback.

      Got access to check events, just surprised to see events:

      BUS2012 CHANGED 05.12.2016 09:00:39 WS91100009 SWW_WI_CREATE_VIA_EVENT

      but actually event should be "BUS2014-->SIGNIFICANTLYCHANGED"

      Please help me out to fix it.

      Regards,

      Abdul Gaffar M.

  • Dec 06, 2016 at 09:20 AM

    Hi,

    In SWEL it is not showing means event is not triggering , thats the reason your worklfow not triggering. Just check if any configuration still pending in SPRO or not.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 08, 2016 at 08:24 AM

    bus2012.jpg

    Deactivated BUS2012--> change event in SWE2 ,working fine now.

    Thanks for supporting.

    Regards,

    abdul gaffar M

    Add comment
    10|10000 characters needed characters exceeded