Skip to Content
0

Implementing Custom Barcode Truetype fonts in BI 4.x (for Webi) for installed on SUSE Linux

Nov 30, 2016 at 02:00 PM

103

avatar image
Former Member

Hello everyone,

We are trying to use custom barcode Truetype fonts in our SUSE Linux environment (11.2) to consume them in our webi reports.

There are few KBAs ad SCN forums which explains how to implement it in a windows environment but did not find any which clearly explains about the Linux.

I tried same configuration(the one explained for windows) in Linux environment and found it not to be working.

The default location for fonts in windows environment is c:\windows\fonts however no KBA clearly explains its equivalent location for Linux.

I visited multiple Linux blogs to find this and came to know the location should be /usr/share/fonts/truetype and copied the font file to this location.

Edited fontaliases.xml at location usr/sap/DYO/sap_bobj/enterprise_xi40/linuxx_x64/fonts and then restarted BO services as well tomcat (this is as per available KBAs)

After this if we go and check in the report and try to change the font in report it do not take effect.

We have also tried copying font to location /usr/sap/DYO/sap_bobj/enterprise_xi40/linux_x64/sapjvm/jre/lib/fonts and test. Still no luck.

Observation is that, the font does show up in the list after the above steps (probably due to editing fontaliases.xml) however it really isn’t taking effect if we change font in the report.

Any help regarding this requirement will be helpful.

Environmental Details:

BI 4.2 SP02 Patch2

O.S- SUSE Linux Enterprise 11.2

Tomcat 8.0

Regards,

Manoj Ambre

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Jawahar Konduru Nov 30, 2016 at 05:01 PM
0

Can you verify if the font you are trying to use, does it support in UNIX? Check below KB in Notes section?

https://launchpad.support.sap.com/#/notes/2010036/E

This process should generally work for other TrueType fonts. For a font to be consistently available across the BI landscape, it is important to ensure the font is a TrueType font and works with Java as well as Unix-based operating systems as not all fonts are universal. If a font does not work, symptoms may range from the font failing to appear in the list of available fonts, to malformed characters in the report when the font is used.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Jawahar,

Thank you for your response on this.

I did check that KBA before posting the issue and made sure these fonts work in wordpad. :)

I think the fontalias.xml file somehow not able to interpret the font file located at /usr/share/fonts/trutype

Any idea if the default fonts directory is right in my case for linux ?

Regards,

Manoj

0