Skip to Content
avatar image
Former Member

MI 7.1 OCA control table problem

I am having serious problems with control "table", is the stage is as follows:

1-I make a" Mobile UI Component "

2-I make to "Application" using the wizzard (next, next, next, finish)

3-I make a node in the Component controller in context with cardinality 0 .. n with 3 string attributes and map in the view context

4-I make a table view using the wizzard using the previously created node, indicating that the first attribute is of type input, the second type button and the third type textedit

5-I make a method in the Component Controller to load the node(add 100 rows,with the same corresponding value of i for the three columns) which is called in the method of the view "wdDoInit"

I run the application on the emulator / pda, and if I do not select any row and performed a vertical scroll or use the buttons "next" and "previous" framework provided by the data in my table are correct, but if I select a row and edit the contents of the input or edit text of the column and I make a scroll or use buttons the data is incorrect, add code in the method "onleadselection" in the table to see what was happening (System .Out.println ("lead selection")) and to my surprise I found that this method is executed two times, this is not right for me, is this normal?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    May 20, 2010 at 08:55 PM

    Hello experts, we found the problem, is really incleible, we are performing a development using the SP09 Patch 0, we have found this problem also in version SP09 Patch 1, the problem is in the client libraries (.. \ MI \ lib \):

    "sap.comtcmobilewdliterendererapi~impl.jar"

    "sap.comtcmobilewdliterendererimpl~impl.jar"

    The problem is related to the load through the input data within a table, which was resolved in version SP08 Patch 2 (see Note 1371589):

    "PDA ESWT runtime - When paging is enabled in a table with input controls, the changed value in the input control is lost When the user pages to the next page and eat back.This issue is resolved in this patch."

    But as I comment this reappears in the SP09, we have replaced these. "Jar" ("sap.comtcmobilewdliterendererapiimpl.jar" and "sap.comtcmobilewdliterendererimplimpl.jar") of the SP09 version we are using for the SP 08 Patch 2 version and it worked correctly

    Now how this error may recur and that no one has reported?, It is believed that the SP09 has to have all the corrections made in previous SP.

    We will report this error.

    regards

    Edited by: asdasdasdasd1 on May 21, 2010 2:17 AM

    Add comment
    10|10000 characters needed characters exceeded