Skip to Content

ORA-01200: actual file size of 437759 is smaller than correct size of 43776

Hi,

I am getting the following unexpected errors while going to create CONTROL files after successful completion of offline/online oracle backup RESTORE (of PRD system) on Quality system. We are following Database specific system copy method to do the same.

All the required pre & post restore activities for the same were carried out. Even the same RESTORE activities are performed with different different online/offline backups of PRD system to do such system copy. But, the thing is stuck at control file creation step with the following same error which is seen again & again after every DB restore operation.....

SQL> @/oracle/AEQ/saptrace/usertrace/CONTROL.SQL
ORACLE instance started.

Total System Global Area 4714397696 bytes
Fixed Size                  2050336 bytes
Variable Size            2365589216 bytes
Database Buffers         2332033024 bytes
Redo Buffers               14725120 bytes
CREATE CONTROLFILE REUSE SET DATABASE "AEQ" RESETLOGS  ARCHIVELOG
*
ERROR at line 1:
ORA-01503: CREATE CONTROLFILE failed
ORA-01200: actual file size of 437759 is smaller than correct size of 437760 blocks
ORA-01110: data file 4: '/oracle/AEQ/sapdata1/sr3_1/sr3.data1'

At OS level the file size of sr3.data1 is found 3586129920 bytes (= 437760 * 8192 bytes).

host1:oraaeq 20> cd /oracle/AEQ/sapdata1/sr3_1
host1:oraaeq 21> ll
total 7004176
-rw-r--r--   1 oraaeq     dba        3586129920 May 11 02:26 sr3.data1

The above mentioned error is coming for all 294 data files. The reported file size difference is only of 1 Block in all data files. The DB block size is 8192 bytes.

Environment: (for SAP QUALITY & PRD systems)

OS: HP_UX ia64 B.11.23

SAP System : SAP ECC 6.0

Database: Oracle 10.2.0.2.0

Your help for this reported issue will be highly appreciated.

Regards,

Bhavik G. Shroff

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on May 11, 2010 at 09:05 AM

    Dear Bhavik,

    Usually this kind of error indicates improper database restoration. But as you said, you tried restoring it again and again..

    I would guess either there may be copy of previous controlfile exist at one of the mirror location, which may causing this error.

    OR have you tried also restoring init).

    Did you find any other points in your further investigation ?

    While seaching on google I got one thread with unique solution....

    [/thread/224262 |/thread/224262 ]

    I´ve got it!!! Since Oracle was complaining about the size of my datafile:
    ORA-01200: actual file size of 1569280 is smaller than correct size of 1569920,
    I decided to "manually extend it". So, I created a file of 640 blocks-length (the difference reported by Oracle between correct size and actual size) and appended it to the datafile with the "cat" command from Unix.
    
    After this I recreated the controlfiles, performed a media recovery and... the database opened!
    
    Then, I made a full export of the database and re-created it (I was afraid about future errors due to my rough solution).

    See if it helps you....

    Regards.

    Rajesh Narkhede

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi,

      The problem is resolved after upgrading HP IVM version from A 3.00 to A3.50. After such up-gradation done by HP Official support, we were able to complete System Copy procedure on affected host with successful Creation of control files for the same.

      Along with your valuable support , the Following Reference links help a lot for the same.

      brrestore-issue-in-hp-ivm-server

      SAP Note 1351051 - Support of Oracle for HP-UX Itanium Integrity VM

      Thanks again.

      Regards,

      Bhavik G. Shroff

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.