Skip to Content
avatar image
Former Member

<element xsi:type="T3" attribute="USD">1.99</element> mapping error ......

Dear All,

I have following source structure from WSDL file which cannot be change.

I have map it with target structure by one to one mapping. But getting following error.

Please guide me do I need to use some node function/technique to map this element with target?

because direct mapping is giving error.

Structure Occurance Type

-<Node> 1..1 T1

--<element> 1..1 T2

---<attribute> 1..1 T3

<element xsi:type="T3" attribute="USD">1.99</element> it is mapped one to one graphical mapping with <element></element>

But in mapping test I am getting error:

The prefix "xsi" for attribute "xsi:type" associated with an element type "<element>" is not bound.

com.sap.aii.utilxi.misc.api.BaseRuntimeException: The prefix "xsi" for attribute "xsi:type" associated with an element type "<element>" is not bound.

at com.sap.aii.mappingtool.tf7.rt.xparser.MTSaxHandler.run(MTSaxHandler.java:253)

at com.sap.aii.mappingtool.tf7.rt.xparser.XParser.run(XParser.java:79)

Caused by: org.xml.sax.SAXParseException: The prefix "xsi" for attribute "xsi:type" associated with an element type "<element>" is not bound.

Regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    May 11, 2010 at 04:01 AM

    Hi Rohan,

    >

    > Structure Occurance Type

    > -<Node> 1..1 T1

    > --<element> 1..1 T2

    > ---<attribute> 1..1 T3

    >

    > <element xsi:type="T3" attribute="USD">1.99</element> it is mapped one to one graphical mapping with <element></element>

    >

    You really want to map attribute value to element in target structure??noamml attribute hold the property,so that was the reason you getting error.

    Regards,

    Raj

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 11, 2010 at 06:19 PM
    The prefix "xsi" for attribute "xsi:type" associated with an element type "<element>" is not bound.

    I dont think the error is due to mapping element with attribute or vice-versa......it is due to the prefix xsi not defined anywhere in your message structure.....if i have to use any prefix then i have to first declare it.....have you done it......hence when you remove xsi there is no error thrown.

    Regards,

    Abhishek.

    Add comment
    10|10000 characters needed characters exceeded