Skip to Content
0
Former Member
May 10, 2010 at 07:49 AM

Flex swfloader cannot load Xcelsius swf file (Version 5.3.0.0)

43 Views

Hi All,

We are working on the integration of Xcelsius and WD. We try to write a wrapper swf to embed Xcelsius swf and the wrapper swf will be embedded into FlashIsland. The code is very simple, like:

<mx:SWFLoader id="xcelsiusLoader" width="100%" height="100%" source="Xcelsius2.swf" />

The wrapper cannot load the Xcelsius swf properly. We got the following errors:

VerifyError: Error #1053: Illegal override of getXcRenderingType in template3941410124-23515-04575-136-035-187121240251025117.

at flash.display::MovieClip/nextFrame()

at mx.managers::SystemManager/deferredNextFrame()

at mx.managers::SystemManager/preloader_initProgressHandler()

at flash.events::EventDispatcher/dispatchEventFunction()

at flash.events::EventDispatcher/dispatchEvent()

at mx.preloaders::Preloader/timerHandler()

at flash.utils::Timer/_timerDispatch()

at flash.utils::Timer/tick()

ReferenceError: Error #1065: Variable CursorManagerStyle_embed_css_Assets_swf_mx_skins_cursor_BusyCursor_1135661634 is not defined.

at flash.display::MovieClip/nextFrame()

at mx.managers::SystemManager/deferredNextFrame()

at mx.managers::SystemManager/preloader_initProgressHandler()

at flash.events::EventDispatcher/dispatchEventFunction()

at flash.events::EventDispatcher/dispatchEvent()

at mx.preloaders::Preloader/timerHandler()

at flash.utils::Timer/_timerDispatch()

at flash.utils::Timer/tick()

ReferenceError: Error #1065: Variable DragManagerStyle_embed_css_Assets_swf_mx_skins_cursor_DragCopy_1892407848 is not defined.

at flash.display::MovieClip/nextFrame()

at mx.managers::SystemManager/deferredNextFrame()

at mx.managers::SystemManager/preloader_initProgressHandler()

at flash.events::EventDispatcher/dispatchEventFunction()

at flash.events::EventDispatcher/dispatchEvent()

at mx.preloaders::Preloader/timerHandler()

at flash.utils::Timer/_timerDispatch()

at flash.utils::Timer/tick()

....

The error occurs when using the version 5.3.0.0 ( build number 12,3,0,670 ). However, if we use the older version 5.2.0.0 ( build number 12,2,0,608 ), then there is no error. The flex version is 2.0.1 Hotfix 3.

Please check.

Thanks & regards,

Johnny Zhuang