Skip to Content
1
Former Member
May 07, 2010 at 02:46 AM

Rule Upload Errors

95 Views

Hello,

We installed SAP Netweaver 7.0 system EHP1 and the GRC AC 5.3 System CME successfully and completed all the post-install activities and all the RAR configuration activities.

We upload all the GRC text files, rules and executed the user/role/profile full sync, batch risk analysis jobs and management report jobs successfully and completed all the post-install activities.

Now we would like to upload rules and mitigations from other Netweaver 7.0 system, which has GRC 5.2 installed. Since that system contains mitigations of 4 different systems i.e. QR2, DR2, PR2. we want only the customized mitigations of PR2 system. We do not want the mitigations of DR2, QR2 systems, since the mitigations of DR2 and QR2 are not required by us.

When we tried to export mitigations from PR2 GRC 5.2 source system and upload it to our new CME GRC AC 5.3 target system, the old GRC 5.2 system does not allow us to select only 1 system i.e. PR2 and so we were forced to select all the 4 systems from GRC AC 5.2 and export all the mitigations into txt file.

Then we manually edited the exported file, to contain mitigations of PR2 only and then through GRC AC 5.3 -> RAR - configuration -> Rule upload -> Tried to upload the mitigations and we got an error "Cannot assign a java.lang.String object or length 6 to host variable 1 which has JDBC type VARCHAR(2)". Rule set upload is not complete due to this error.

Please note that CME is the target GRC AC 5.3 System and PR2 is the source GRC AC 5.2 system, from where the mitigations are to be uploaded into CME 5.3 system.

Kindly let us know, how to resolve this error.

Thanks,

Imran