Skip to Content
May 05, 2010 at 12:13 PM

Crystal Reports addin not working anymore with newer CR version


Hi all,

I developed a Crystal Reports addin about one year ago, which was working fine. Now I need this addin again to make some enhancements, so I installed Crystal Reports 2008 and Visual Studio 2008 again, but the addin functionality doesn't work anymore.

When I start Crystal Reports and open a report there is no "add-in" menu anymore. I also tried to use the cscFindSubreports sample addin, but it doesn't work either.

When I imported my addin project into Visual Studio I got a message that there is a newer version of Crystal Reports on this pc and that the project will be converted. Afterwards I saw that the ICommand interface has a new method "getMenuType", which needs to be implemented. This method should return an integer, so I tried different values (0,1,...) but nothing changes: still there is no "add-in" menu in Crystal Reports available.

I searched for information within the Crystal Reports Developer Guide and "creating custom addins" document, but there is no information available concerning this method.

Does anyone know about the return values of this method? Can this be the issue, why the "add-in" isn't appearing anymore in Crystal Reports?

I use Crystal Reports 2008 version: The addins are correctly loaded, as they appear in the loaded modules dialog of Crystal Reports, but there is no menu appearing.

Thanks a lot for your help,