Skip to Content
0
Former Member
May 05, 2010 at 07:57 AM

Crystal Reports Java Eclipse Bug - Displaying JSF Pojo Data

45 Views

Hmm, we thought this was a database issue but it seems to be also affecting persistence with POJO data objects, so perhaps it is a bug?

We have a simple java jsf view with a SelectOneMenu and a submit button. When selecting a default report from the drop down menu (that is a finished report with data inside) it displays immediately. However when we select a second report from the menu, which pushes POJO data (fromt the simplePOJO class) we have to press the submit button (or press the refresh icon in the report viewer) twice to even see the correct report and actually a third time to get it to display the pushed data to the report.

We have tried inserting a few methods to try to flush or renew the data without success.

reportClientDoc.refreshReportDocument()

or

reportClientDoc.flushRequests()

We have also tried changing the order of setting the datasource and opening the document, as well as recreating a new reportdocument and or closing the document - none of which seem to have effect.

Perhaps someone knows a solution for this bug - our code will be placed below.

Thanks a bunch for any help - would be much appreciated.