Skip to Content
avatar image
Former Member

*** error => connect failed with sql error '12541'

Hi All,

I have two SAP AS installed on same host.

1. Netweaver 7.0 with oracle as DB.

2. ECC IDES with oracle as DB.

both dont share oracle home and their port numbers are also different.

1527 for NW AS and 1528 for ECC IDES.

Yesterday, after installation of IDES both were running fine and today NW is running fine but IDES is not starting up.

The logs are posted in next port.

Please help me in resolving this.

Regards,

Sharib

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Apr 28, 2010 at 12:31 PM

    Hi,

    Please check listener and tnsnames files, if ports are listed correctly.

    Its a listener problem only.

    You may need to check file at profile/oracle directory.

    Check and revert.

    Regards,

    Gagan Deep Kaushal

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 28, 2010 at 12:26 PM

    dev_w0 log is :......

    -


    trc file: "dev_w0", trc level: 1, release: "701"

    -


    *

    • ACTIVE TRACE LEVEL 1

    • ACTIVE TRACE COMPONENTS all, MJ

    *

    B

    B Wed Apr 28 17:13:41 2010

    B create_con (con_name=R/3)

    B Loading DB library 'E:\usr\sap\U2E\DVEBMGS02\exe\dboraslib.dll' ...

    B Library 'E:\usr\sap\U2E\DVEBMGS02\exe\dboraslib.dll' loaded

    B Version of 'E:\usr\sap\U2E\DVEBMGS02\exe\dboraslib.dll' is "700.08", patchlevel (0.25)

    B New connection 0 created

    M sysno 02

    M sid U2E

    M systemid 562 (PC with Windows NT)

    M relno 7010

    M patchlevel 0

    M patchno 32

    M intno 20020600

    M make: multithreaded, Unicode, 64 bit, optimized

    M pid 2212

    M

    M kernel runs with dp version 241000(ext=110000) (@(#) DPLIB-INT-VERSION-241000-UC)

    M length of sys_adm_ext is 576 bytes

    M ***LOG Q0Q=> tskh_init, WPStart (Workproc 0 2212) [dpxxdisp.c 1348]

    I MtxInit: 30000 0 0

    M DpSysAdmExtCreate: ABAP is active

    M DpSysAdmExtCreate: VMC (JAVA VM in WP) is not active

    M DpShMCreate: sizeof(wp_adm) 29792 (1752)

    M DpShMCreate: sizeof(tm_adm) 5912704 (29416)

    M DpShMCreate: sizeof(wp_ca_adm) 24064 (80)

    M DpShMCreate: sizeof(appc_ca_adm) 8000 (80)

    M DpCommTableSize: max/headSize/ftSize/tableSize=500/16/552064/552080

    M DpShMCreate: sizeof(comm_adm) 552080 (1088)

    M DpSlockTableSize: max/headSize/ftSize/fiSize/tableSize=0/0/0/0/0

    M DpShMCreate: sizeof(slock_adm) 0 (104)

    M DpFileTableSize: max/headSize/ftSize/tableSize=0/0/0/0

    M DpShMCreate: sizeof(file_adm) 0 (72)

    M DpShMCreate: sizeof(vmc_adm) 0 (1864)

    M DpShMCreate: sizeof(wall_adm) (41664/36752/64/192)

    M DpShMCreate: sizeof(gw_adm) 48

    M DpShMCreate: SHM_DP_ADM_KEY (addr: 000000000B2B0050, size: 6614144)

    M DpShMCreate: allocated sys_adm at 000000000B2B0050

    M DpShMCreate: allocated wp_adm at 000000000B2B2270

    M DpShMCreate: allocated tm_adm_list at 000000000B2B96D0

    M DpShMCreate: allocated tm_adm at 000000000B2B9730

    M DpShMCreate: allocated wp_ca_adm at 000000000B85CFB0

    M DpShMCreate: allocated appc_ca_adm at 000000000B862DB0

    M DpShMCreate: allocated comm_adm at 000000000B864CF0

    M DpShMCreate: system runs without slock table

    M DpShMCreate: system runs without file table

    M DpShMCreate: allocated vmc_adm_list at 000000000B8EB980

    M DpShMCreate: allocated gw_adm at 000000000B8EBA00

    M DpShMCreate: system runs without vmc_adm

    M DpShMCreate: allocated ca_info at 000000000B8EBA30

    M DpShMCreate: allocated wall_adm at 000000000B8EBA40

    M rdisp/queue_size_check_value : -> off

    M ThTaskStatus: rdisp/reset_online_during_debug 0

    X EmInit: MmSetImplementation( 2 ).

    X MM global diagnostic options set: 0

    X <ES> client 0 initializing ....

    X Using implementation view

    X <EsNT> Using memory model view.

    M <EsNT> Memory Reset disabled as NT default

    X ES initialized.

    M

    M Wed Apr 28 17:13:42 2010

    M ThInit: running on host uipl-sdsrv

    M

    M Wed Apr 28 17:13:43 2010

    M calling db_connect ...

    C Prepending E:\usr\sap\U2E\DVEBMGS02\exe to Path.

    C Oracle Client Version: '10.2.0.4.0'

    C Client NLS setting (OCINlsGetInfo): 'AMERICAN_AMERICA.UTF8'

    C Logon as OPS$-user to get SAPSR3's password

    C Connecting as /@U2E on connection 0 (nls_hdl 0) ... (dbsl 700 151208)

    C Nls CharacterSet NationalCharSet C EnvHp ErrHp ErrHpBatch

    C 0 UTF8 0 000000000E0320C0 00000000024BA290 00000000024BBAB8

    C Attaching to DB Server U2E (con_hdl=0,svchp=00000000024BB978,srvhp=000000000E03A118)

    C

    C Wed Apr 28 17:13:44 2010

    C *** ERROR => OCI-call 'OCIServerAttach' failed with rc=12541

    [dboci.c 4447]

    C *** ERROR => CONNECT failed with sql error '12541'

    [dbsloci.c 11175]

    C Try to connect with default password

    C Connecting as SAPSR3/<pwd>@U2E on connection 0 (nls_hdl 0) ... (dbsl 700 151208)

    C Nls CharacterSet NationalCharSet C EnvHp ErrHp ErrHpBatch

    C 0 UTF8 0 000000000E0320C0 00000000024BA290 00000000024BBAB8

    C Detaching from DB Server (con_hdl=0,svchp=00000000024BB978,srvhp=000000000E03A118)

    C Attaching to DB Server U2E (con_hdl=0,svchp=00000000024BB978,srvhp=000000000E03A118)

    C

    C Wed Apr 28 17:13:45 2010

    C *** ERROR => OCI-call 'OCIServerAttach' failed with rc=12541

    [dboci.c 4447]

    C *** ERROR => CONNECT failed with sql error '12541'

    [dbsloci.c 11175]

    B ***LOG BY2=> sql error 12541 performing CON [dbsh#2 @ 1208] [dbsh 1208 ]

    B ***LOG BY0=> ORA-12541: TNS:no listener [dbsh#2 @ 1208] [dbsh 1208 ]

    B ***LOG BY2=> sql error 12541 performing CON [dblink#3 @ 431] [dblink 0431 ]

    B ***LOG BY0=> ORA-12541: TNS:no listener [dblink#3 @ 431] [dblink 0431 ]

    M ***LOG R19=> ThInit, db_connect ( DB-Connect 000256) [thxxhead.c 1449]

    M in_ThErrHandle: 1

    M *** ERROR => ThInit: db_connect (step 1, th_errno 13, action 3, level 1) [thxxhead.c 10563]

    M

    M Info for wp 0

    M

    M pid = 2212

    M severity = 0

    M status = 0

    M stat = WP_RUN

    M waiting_for = NO_WAITING

    M reqtype = DP_RQ_DIAWP

    M act_reqtype = NO_REQTYPE

    M rq_info = 0

    M tid = -1

    M mode = 255

    M len = -1

    M rq_id = 65535

    M rq_source =

    M last_tid = 0

    M last_mode = 0

    M semaphore = 0

    M act_cs_count = 0

    M csTrack = 0

    M csTrackRwExcl = 0

    M csTrackRwShrd = 0

    M mode_cleaned_counter = 0

    M control_flag = 0

    M int_checked_resource(RFC) = 0

    M ext_checked_resource(RFC) = 0

    M int_checked_resource(HTTP) = 0

    M ext_checked_resource(HTTP) = 0

    M report = > <

    M action = 0

    M tab_name = > <

    M attachedVm = no VM

    M

    M *

    M * LOCATION SAP-Server uipl-sdsrv_U2E_02 on host uipl-sdsrv (wp 0)

    M * ERROR ThInit: db_connect

    M *

    M * TIME Wed Apr 28 17:13:45 2010

    M * RELEASE 701

    M * COMPONENT Taskhandler

    M * VERSION 1

    M * RC 13

    M * MODULE thxxhead.c

    M * LINE 10783

    M * COUNTER 1

    M *

    M *****************************************************************************

    M

    M PfStatDisconnect: disconnect statistics

    M Entering TH_CALLHOOKS

    M ThCallHooks: call hook >BtcCallLgCl< for event BEFORE_DUMP

    M ThCallHooks: call hook >ThrSaveSPAFields< for event BEFORE_DUMP

    M *** ERROR => ThrSaveSPAFields: no valid thr_wpadm [thxxrun1.c 723]

    M *** ERROR => ThCallHooks: event handler ThrSaveSPAFields for event BEFORE_DUMP failed [thxxtool3.c 261]

    M Entering ThSetStatError

    M ThIErrHandle: do not call ThrCoreInfo (no_core_info=0, in_dynp_env=0)

    M Entering ThReadDetachMode

    M call ThrShutDown (1)...

    M ***LOG Q02=> wp_halt, WPStop (Workproc 0 2212) [dpnttool.c 334]

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      thisis purely Listner problem, The listener for NW with port 1527 is running but the listner for ECC isnot running with prot 1528(as per your message). so login with the another ECC <SID> using ora<sid> user and then start the listener of that <SID>. Then try R3trans -d, it should work....

      Regards,

      Kishore

  • avatar image
    Former Member
    Apr 28, 2010 at 12:49 PM

    Dear Sharib,

    Kindly let me know Do you have two different DB or both systems are using the same DB (Oracle)

    As per the given SQL error you listener is not working . Just confirm there are two listener process running at OS level .

    Check the same and share result .

    Thanks and Regards,

    Arun Kumar

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 30, 2010 at 04:27 PM

    HI All,

    Thanks for the fast reply.

    I have resolved the issue.... As it was after second AS installation, the listener services were manual for second AS.(to be started manually).

    All we have to do is that, we have to start those services and make those service setting as "Automatic".

    And restart the SAP server again.

    Regards,

    Sharib

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 08, 2015 at 10:53 AM

    Hi Experts

    I'm getting the same error while installing database instance in distributed environment (ASCS is already installed successfully). Can anyone please help in getting rid of this..

    Error in Import ABAP phase -

    Logs from R3load.exe.log file -

    Logs from sapinst_dev.log file -

    Regards

    Hardeep


    1.JPG (27.5 kB)
    2.JPG (75.5 kB)
    3.png (148.4 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member M. RAHAMAN

      I used the same installable in DEV environment and was able to successfully install it. But in QA I'm facing this issue. So, patch might not be a problem here.

      Any other suggestion ? Can it be some other issue, since it is failing at 'Import ABAP' phase so I doubt that something is stopping the Database Server to import data from App Server.

      Thanks for your earlier suggestion by the way. 😊