Skip to Content

[Bug?] "Failed to load followed tags" upon first visit to dashboard

Is anybody else getting the message "Failed to load followed tags" when first visiting ones dashboard after logging in? It's happening consistently for me with Firefox both on my own laptop and at work:

The box of followed activity is the empty:

Not a big deal as the tags load upon refreshing the screen - just wondering if this is a known issue/bug as I didn't yet find a discussion thread about it.

Cheers

Baerbel

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • Best Answer
    Jan 18 at 09:44 AM

    Hi Bärbel,

    I wonder if the error will be reproduced if you specifically click on Logout when you are on your Profile, and then log back in using SSO.

    Regarding tags, I found this:

    https://answers.sap.com/tags.html

    When you click on any of the tags you used in this post, then you have a widget on the right with popular tags, which when you expand it has a link to "View All" which will bring you to the URL I posted above.

    KR,

    Vladimir

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 01 at 08:05 AM

    Vladimir GERSHANOV

    Hi Vladimir!

    Here is an update: I no longer get the error message and the followed activities load immediately when I access my dashboard. I however don't really remember since when it's working again as I wasn't keeping too close attentition to it.

    Cheers

    Bärbel

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 15 at 01:44 PM

    Hi, Bärbel,

    Can you make a screenshot of the tags that you follow (per the below link) and share it with us:

    https://people.sap.com/#following:tags

    I'd like to try and reproduce it, but currently with the tags I follow it doesn't happen.

    KR,

    Vladimir

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 15 at 05:00 PM

    Hi, Bärbel,

    I've added your tags to my followed tags and will check if it's reproducible for me.

    Since you mentioned you can reproduce it every time you first log in, could you open the devtools (F12 or Fn+F12 on mac) before you log into Profile and then perform the login.

    If you have reproduced the error upon your login, then you should see an error code 401 / 403 or etc. in the following call:

    https://people-qa.sap.com/api_v1/following/load_tags

    Would be great if you can check and post how this call looks for you and what error code you see there.

    Also an approximate timestamp would be great for us to check the logs.

    Thanks,

    Vladimir


    Add comment
    10|10000 characters needed characters exceeded

    • Hi Vladimir,

      the issue doesn't happen right upon login but whenever I - after logging in - go to the dashboard via my profile for the first time. As I was already logged in when I saw you response I started the devtools via F12 and then went through the motions. But, never having used those tools I don't really know where to look for error codes or other helpful information. There are too many tabs and nodes which don't tell me much of anything, I'm afraid.

      But, is this what you are looking for?

      This happened within 10 minutes before writing this comment at 5:30p GMT

      Does this help?

      Cheers

      Bärbel

  • Jan 17 at 11:28 AM

    Hi, Bärbel,
    Thanks for the screenshot, this is exactly what I was asking for.
    I've managed to reproduce a similar error, but not exactly this one so far.

    What I can suggest at this point is trying to logout, and then log in again, because it does seem to be related to an expired session.
    Also try adding another followed tag, then visit the dashboard again and if needed remove it later from followed tags.

    Let me know if any of the above suggestions fixes it. Perhaps you'll have to monitor it for a few days, since sessions are several hours long, so they don't expire too quickly.

    Kind Regards,

    Vladimir

    Add comment
    10|10000 characters needed characters exceeded

    • Vladimir GERSHANOV

      Hi Vladimir,

      not sure if this can be related to an expired session as I also get the error message shortly after logging in when I visit the dashboard for the first time. My incoming link is usually answers.sap.com which shows me as not logged-in. I then click on either the profile avatar or the login-button, get automatically logged-in (I have SSO enabled) and more often than not open my dashboard in a 2nd tab. This is when I get the message.

      I'll try following another tag, once I find a link to the list of all primary tags available. Weirdly enough, the resource-page Use of tags in the SAP Community doesn't seem to contain a link to a list of primary tags which would make it a lot easier to select one (esp. as that page gets linked to a couple of times from the Resources page)!

      Cheers

      Bärbel