Skip to Content
avatar image
Former Member

MaxDB Database Startup Error

The maxDB database is not starting,

When I type

dbmcli -n mgiusdgrc1 -d CME -u superdba,<passwd> db_online, I get the following error.

Error! Connection failed to node <hostname> for database CME:

-24700, ERR_DBMSRV_NOSTART: Could not start DBM Server.

-24832, ERR_SHMNOTAVAILABLE: Shared memory not available.

-24827, ERR_SHMALLOCFAILED: ID E:\sapdb\data\wrk\CME.dbm.shi, requested size 260010,

Opening shared memory file E:\sapdb\data\wrk\CME.dbm.shi failed, rc = 5.

I tried to rename the file CME.dbm.shi, but it did not work.

Currently we have 8 GB of physical memory RAM allocated on Wndows 2008 Server and paging size specified is 16 GB.

1- Can anyone help in resolving the above shared memory error?

2- Are there any logfiles and specific error messages that I need to check, to resolve the MaxDB startup issue error.

Thanks in advance.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    Apr 21, 2010 at 04:53 PM

    - As which user are you trying to start the database?

    - You have UAC disabled?

    Markus

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 11, 2014 at 11:04 PM

    Hi all, I see that this was solved. Good. I just wanted to write that I aslo got:

    Error! Connection failed to node <hostname> for database CME:

    -24700, ERR_DBMSRV_NOSTART: Could not start DBM Server.

    -24832, ERR_SHMNOTAVAILABLE: Shared memory not available.

    -24827, ERR_SHMALLOCFAILED: ID E:\sapdb\data\wrk\CME.dbm.shi, requested size 260010,

    Opening shared memory file E:\sapdb\data\wrk\CME.dbm.shi failed, rc = 5.

    when using dbmcli.

    My problem was that my database logs was full. I installed maxdb database studio 7.9 for my maxdb 7.7. There it was red light 'Full logs'. I put the log in overwrite mode and the problem disapeared.

    Thanks

    Add comment
    10|10000 characters needed characters exceeded