Skip to Content

How to delete AUSP table data?

Hello.

Invalid data entered in AUSP table
I don't know where it was inserted, but it contains characteristic values that are not related to the assigned class.
As a result, other BAPIs and FMs don't work normally.
for example, We can't implement 'BAPI_OBJCL_CHANGE'.
The message is 'inconsistent characteristic value assignment', message no. is C1821

I can resolve the inconsistencies individually via the screen.
But there are a lot of error data, I want to do batch deletions through BAPI or FM.
None of the BAPIs or FMs from the search work properly.
I think it's because they're unrelated to class assignment.

There are no classes in the KSSK table that are related to that characteristic
Help me figure out how we can solve it.

Thank you!

Add comment
10|10000 characters needed characters exceeded

  • Before you actually plan to delete them manually i think it makes sense to first find the root cause. Such inconsistencies can be created again in the system. Check in CDHDR for Classify object and CDPOS for ABAUSP table for the details of who has created them if you are able to find something then proceed on fixing the root cause. Coming to the second point how to fix them at a mass scale i believe since the BAPI's you have already tried and they fail, so ideally you need to replicate your frontend step in a BDC and run the report.

    Nabheet

  • Thank you for your reply.
    As a result of the cause analysis, temporary equipment number (ex:TM000001) is set before saving the equipment. It was identified as an error caused by someone setting up the equipment with the temporary number, and some characteristics were assigned to it.

    SAP internal error is thought to be automatically copied with temporary equipment number during equipment creation

    To solve this problem,
    1) After creating a new class and specifying the incorrectly specified characteristics,
    2) Assign a new class to the object (using BAPI_OBJCL_CREATE)
    3) Unassigning a new class to the object ( using BAPI_OBJCL_DELETE)
    We solved the problem by doing

    Thank you for your interest.

  • Get RSS Feed

1 Answer

  • Jan 14 at 10:59 AM

    There was an old program (RCLAUSP4) to correct such database inconsistencies, check if available in your version.

    Add comment
    10|10000 characters needed characters exceeded