Skip to Content
0
Former Member
Apr 20, 2010 at 05:20 PM

Trouble with unprintable characters in Adobe Print form

911 Views

Hi experts,

I'm trying to implement an adobe printform containing a PDF417 Barcode. To separate the datafields within the barcode, i have to use some unprinteable characters like hex 1E or 1C and so on.

I had the same issue in SMARTFORMS a few years ago, but was able to solve it in smartforms using /0x1E or /0x1C. Now I tried the same in Adobe Forms, but there comes an error in SM21 (syslog), telling me, that there was a problem during a Render operation. (Processing exception during a "Render" operation... A problem was encountered with the results: RenderResult array is null.)

I tried to use this coding as well:

  data: zrecsep type c.

field-symbols: <f>.
label_data_barcode-recsep   = '1E'. "recsep is type x
ASSIGN label_data_barcode-recsep to <f> CASTING TYPE C.
move <f> to zrecsep.
clear <f>.

After that, zrecsep contains '#', but in hex the correct value '1E'.

This coding works for all printable characters, such as hex 66 for 'f' or hex 5B for '[', but not for unrintable characters like hex 1E. In case of an unprintable character, a new syslog entry appears.

Any ideas?

Many thanks

Ralf