Skip to Content

64 bit install issue on Windows 7

I am using , in the .NET C# application

SAP CRYSTAL REPORTS RUNTIME ENGINE FOR .NET FRAMEWORK (64 BIT)

13.0.24.2970

Things would compile fine, but I found that reports would not run. I downloaded and installed:

SAP CRYSTAL REPORTS VERSION FOR VISUAL STUDIO

13.0.24.2970

and reports would function. Note that the my development machine is a windows 10 machine. Note also that I am using Visual Studio 2017.

The client has a windows 7 workstation machine, that does not have visual studio installed on it. In attempting to install SAP CRYSTAL REPORTS VERSION FOR VISUAL STUDIO 13.0.24.2970 a error is presented indicating that Visual Studio is not installed, and that the installation cannot continue.

How do I get this to install so that reports will function? I'm not sure where the install program came from (I'm guessing that it was a template, probably of a lesser version than VS 2017).

Any help would be appreciated...even a file list of the DLL's installed by the

CRYSTAL REPORTS VERSION FOR VISUAL STUDIO

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jan 14 at 12:46 PM

    Hello Chester,

    for such an issue please open an SAP Support message and attach the necessary logfiles.

    Like that, the colleagues can take a look at the system and analyze the logfiles. Also, the problem can then quickly be distributed in SAP directly to the responsible team to solve the issue.

    Thanks and best regards

    Stefan Jakobi

    Product Management SAP SE

    CLM

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 14 at 08:55 PM

    What logfiles are you referencing and how do I get them?

    The basic problem is simply "Reports don't run on the 64 bit version OS" because the files don't line up to the application. In order to solve this, I tried to install the crystal reports for visual studio - which worked fine for me since I had visual studio installed. Client workstations don't however, and when you try to run the install for it a messagebox dialog pops up telling you that visual studio is not installed and the installation cannot continue.

    Add comment
    10|10000 characters needed characters exceeded