Skip to Content
avatar image
Former Member

After Upgrade to ECC, Proxy is not sending empty tags to XI

Hi,

Recently we upgraded our quality system to ECC6.0 from SAP4.7. During integration testing we found some of the fields in IDOC are not getting populated because the mapping is not getting full filled due to missing source tags from proxy.

The problem is when ECC-proxy returns the data to XI then it does not sent the empty tags which was not the case with SAP4.7. In 4.7 we were getting the empty tags from proxy.

File --->XI ->Proxy->XI---->IDOC.

So what is happening now is, in the mapping when source field is missing then target field does not get created due to suppressed value of source.

I know I can do changes in mapping and use MapWithDefault if the source field is missing, but this I have to do in all interfaces and in almost each field. Is there anything else which I can do apart from changing the mapping?

Please let me know if anyone has faced similar issues and best possible solution.

Regards,

Sarvesh

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Apr 14, 2010 at 05:39 AM

    Hi Sarvesh,

    Check if you were using Extended XML Handling with your earlier version. This should be the option.

    http://help.sap.com/saphelp_nw04/helpdata/en/73/3f5c3c3906b006e10000000a11402f/content.htm

    Regards,

    Prateek

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Prateek,

      Thanks your for your reply.

      I checked and found that we are not using Extended XML Handling in SAP 4.7 but we get the empty tags from proxy.

      The new thing in ECC proxy I have noticed is that it checks the cardinality of each field but in previous version this was not the case. So it looks like when the cardinality is as 0:1 then ECC suppress the empty tags (if they are not filled).

      I hope the sap link which you suggest will help me. So I will check this and let you know. Thanks!

      Regards,

      Sarvesh

  • avatar image
    Former Member
    May 10, 2010 at 08:48 PM

    To solve the issue we did some small fixes in XI.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sarvesh,

      Now I have the same issue in my project. How did you solve this? I need empty tags for the non-filled fields in the outbound proxy. Please let me know.

      Thanks,

      Koti