Skip to Content
avatar image
Former Member

SOAMANAGER - Open Web Service navigator for selected binding - Error

Hi,

I am trying to test a web service by utilizing through SOAMANAGER the "Open Web Service Navigator for Selected Binding" link. I have set up through the VisAd Web Service Container what I think is the correct proxy information. When I select test and I enter the required parameters for th WS I receive the following error:

An error has occurred. Maybe the request is not accepted by the server:

Proxy responded: HTTP/1.0 400 protocol error

Through the System Global Settings => Access Information J2EE server I set up a connection to hostname solmand.corp.abc.com port number 50100.

Proxy definition inthe Web Service Container on solmand is:

Proxy Host: serverabc.corp.abc.com

Proxy Port: 8000

Bypass proxy Server For Local addresses is checked

Allowed Hosts is *

SOAMANAGER is launched from serverabc.corp.oge.com to test a WS that resides there. Item of note is that the WS is set up with SSL Basic Authentication.

Any suggestions would be appreciated. Thanks.

David Carr

Netweaver Admin

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Apr 22, 2010 at 05:40 AM

    Hi,

    Can you please check if all your configurations are in place using this note

    sap note 1319742

    Regards,

    Srinivas

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi ,

      I guess i figured out your issue.

      Go to SOAMANAGER->Technical setting->System Global setting->Acess Information J2ee Server

      Please mention your J2ee Server

      Host

      PortNumber

      port type http

      Save and try reopneing the WSnavigator link whcih you were trying earlier

      This will solve,if not post your qurery

      Regards,

      Srinivas

      -Use the stars if helpful 😊

  • avatar image
    Former Member
    Apr 23, 2010 at 07:51 AM

    Hi,

    Post wsdl here, you can mask server:port etc.

    Regards,

    Gourav

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 05, 2010 at 11:45 AM

    Have you got the solution for this??

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I have not found a solution as yet. I stepped back and tried what I thought was a more simple sceanrio where I am not trying to use HTTPS/SSL. I configured it as:

      Transport Gurantee Type: Secure Conversation

      HTTP Authentication: User ID/Password

      Transport Protocol: HTTP Protocol

      Signature Expected: No Signature Expected

      Encryption Expected: No Encryption Expected

      Add Signature No Not Add Signature

      Encryption: Do Not Encrypt Message

      Use Time Stamp: Use IncludeTimeStamp

      Used WS Secure Conversation: WS Secure Conversation protocol is used.

      I receive the following:

      Message Envelope not found. Probably empty soap message.

      HTTP/1.1 500 Message E 1S 406 cannot be processed in plugin mode HTTP

      Set-Cookie: <value is hidden>

      content-type: text/xml; charset=utf-8

      content-length: 0

      accept: text/xml

      sap-srt_id: 20100511/104245/v1.00_final_6.40/4BE97A855E1103FBE1008000A7A1104B

      server: SAP Web Application Server (1.0;700)

      Not sure where to go from here. Thanks.

      David