Skip to Content
avatar image
Former Member

t-code redirects always to the same/wrong URL ( /sap/public/myssocntl? )

Hi everyone,

When I execute any t-code in SAP (e.g. solman_setup, soamanager), i am always re-directed to the same URL:

http://<host.company.com>:50002/sap/public/myssocntl?sap-client=001

I created an HTTP Service with the Port 50002 in „Internet Communication Manager Administration“. All transactions like solman_setup were accesable. Everything was working fine.

After system restart the temporary connection was of course gone, therefore I created the http connection in RZ10 but this time is used the HTTP Port 50000, and restarted sap r3.

In smicm / Services the created HTTP status is activ.

smicm-services.png

But all t-codes (solman_setup) redirects to the wrong Port.

http://<host.company.com>:50002/sap/public/myssocntl?sap-client=001

and not to the new HTTP Port

http://<host.company.com>:50000/...

I still can access the SOLMAN_SETUP by using the url directly:

http://<host.company.com>:50000/sap/bc/webdynpro/sap/wd_sise_main_app?sap-language=EN

https://<host.company.com>:50001/sap/bc/webdynpro/sap/wd_sise_main_app?sap-language=EN

regards

Ben

smicm-services.png (12.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Dec 06, 2016 at 09:36 PM

    Can you attach ICM log.

    Also Can you test "ping" service from SICF and see what is the port?

    What information you can see when going to transaction SICF, Menu GoTo -> Port information

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 29, 2016 at 12:46 PM

    Hi Ben,

    What port is used if you test the service "myssocntl" in SICF? Maybe you need to deactivate/activate this service.

    Kind regards,
    Martin

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 10, 2017 at 12:42 PM

    please share ICM logs. Also check service properties in SICF.

    Regards,

    Amit T

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 10, 2017 at 12:40 PM

    Check your ICM parameters,

    icm/server_port_X and icm/HTTP/j2ee_X

    Regards, JP

    Add comment
    10|10000 characters needed characters exceeded