Skip to Content
0

[SAP Hana Vora] HANA couldn't read data from Vora

Nov 29, 2016 at 10:04 AM

50

avatar image
Former Member

Hello,

we are integrating our hadoop platform to SAP Hana DB but HANA couldn't read data from Hadoop.

We have a hadoop cluster managed by Ambari 2.2 with HDP 2.3.4.7-4.

All nodes are using Linux SLES 11 SP4 created in Open Stack.

HANA version is 1.00.122.01.1470046197 (fa/hana1sp12).

We have installed SAP HANA Vora under the direction of SAP HANA Academy. Then installed Spark Controller 1.5 PL5 ( HANASPARKCTRL00P_5-70001262.RPM). Our Spark version is 1.5.2.2.3. Vora version is 1.2.48.113.

After all service started, we cerated a remote data source as follows:

CREATE REMOTE SOURCE "SPARK" ADAPTER "sparksql"

CONFIGURATION 'port=7860;ssl_mode=disabled;server=xxx,xxx,xxx,xxx;'
WITH CREDENTIAL TYPE 'PASSWORD' USING 'user=xxx;password=xxx';

And then it succeed. I could also add a virtual table "SPARK_FACTS" to my schema using this source.

Then problem occurs:

In my schema, I could open the definition of the table SPARK_FACTS, and it works so that the column names and data type are displayed.

But if I want to see the content by clicking "open content", a new window appeared and a background job started while no data is displayed. I can see the query task is running in the right-bottom corner of HANA Studio.(So it is with Data Preview)

It seems no end unless I canceled the task.

hanaes log:

hana-controller.txt

When I checked these data in Vora tools, I could see all the data in Data Browser.

Does anyone have experience dealing with this problem?

Our goal is to review data in HANA studio.

Thank you in advance.

Best Regards,

Grace.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers