Skip to Content
avatar image
Former Member

CANNOT_READ_PAYLOAD error in Web Service Response

Hi experts,

We are deploying a webservice on SAP PI, when we call the SAP PI webservice directly, everything works normal, and we get a response.

When we call the SAP PI web service through a different J2EE web service, the fields in response are null(though the SOAP message is received), because PI is not able to get the PAYLOAD in the SOAP request, the following error is obtained in the response.

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <!-- Request Message Mapping

-->

- http://sap.com/xi/XI/Message/30" xmlns:SOAP=" http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">

<SAP:Category>XIServer</SAP:Category>

<SAP:Code area="MAPPING">CANNOT_READ_PAYLOAD</SAP:Code>

<SAP:P1 />

<SAP:P2 />

<SAP:P3 />

<SAP:P4 />

<SAP:AdditionalText />

<SAP:ApplicationFaultMessage namespace="" />

<SAP:Stack>Unable to read payload from the message object</SAP:Stack>

<SAP:Retry>N</SAP:Retry>

</SAP:Error>

Every other configuration and the web service settings used are the same, Only the direct call to a WEB SERVICE DEPLOYED IN SAP PI engine is redirected through a WEB SERVICE deployed in J2EE engine to the SAP PI engine, is causing problems.

Please Help..Urgently.

Thanks..

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Apr 06, 2010 at 02:23 PM

    Hi,

    Are both requests (plain PI and WS encapsulated) strictily identical ? If PI can not parse body when intermediate WS is invoked, it might be due to a (slight) change in the WS request (ie namespace, declaration etc) ...

    Chris

    Add comment
    10|10000 characters needed characters exceeded