Skip to Content
avatar image
Former Member

Solution Manager SLD not getting updated completely

Hi,

I have bridged my Solution manager SLD to the central SLD in the landscape. The connectivity is working fine.

For one system in the landscape connected to central SLD -I can see the entry for both ABAP and Java component, but in the SolMan SLD tha data for ABAP component is getting populated while for Java component the entry is not coming.

Can any one help me with the possible reason for this discrepancy?

Regards

Dhiraj

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Apr 09, 2010 at 02:30 PM

    Hi Dhiraj

    Is the CIM and Netweaver version of Solman SLD and Central SLD the same

    Sometimes you may get issues in sync options if the source and target SLD are different versions or CIM patch levels

    Best wishes

    Stuart

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Stuart,

      Yes both checks suggested are fulfilled. Infact I am able to get the ABAP data updated but not the Java. Seems there is issue in transfer of Java data to central SLD.

      Regards

      Dhiraj

  • avatar image
    Former Member
    Apr 06, 2010 at 12:52 PM

    Hi

    Normaly, if the Fetch Job is running successfully the Java System should appear in the Buttom of SMSY under System Comonents --> JAVA.

    If the Job is not running; Check the Tx: " sldcheck " the Function LCR_LIST_BUSINESS_SYSTEMS should terminate successfully.

    regards

    Murat

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Dhiraj

      It seems that the data is not synchronized correctly!

      Delete the old entry in the SLD. Verify that the Username and PW you are using are correct (not locked, permission etc) in the SLD satellite system (Data Supplier). Then restart the JAVA Engine to trigger a data transfer.

      Regards

      Murat

  • avatar image
    Former Member
    Apr 07, 2010 at 09:24 AM

    Please check when is the last time that the java component information is updated to the central SLD. Please try updating the information manually from the Visual Adminsitrator and check if the information is also passed through the SLD bridge

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 09, 2010 at 03:36 PM

    Hi

    How did you setup the bridge - i.e what forwarding option are you using?

    In the past I remember a similiar issue because the J2EE Data Supplier could not send information to a gateway - it actually sends the information direct via HTTP

    However if you are forwarding via a synch option in the SLD itself and not using bridge distribution then ideally the JAVA system should be part of any ALL or LD based sync

    Are no JAVA systems forwarding - what about ABAP and JAVA dual stacks?

    Best wishes

    Stuart

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 09, 2010 at 03:52 PM

    Hi

    I also had a look through this thread and it is not yet clear if you have triggered a manual data supply run from Visual Admin tool -> SLD Data Suppliers tabs of the missing J2EE systems as suggested before

    In previous occurances of this issue, if the last update was before the sync was set up- there may not have been a subsequent update to forward to the data to the Solution Manager SLD - some sync options may only react to data supply updates they may not automatically push all the data as soon as you setup the bridge - therefore you may need to manually send an update from the J2EE Visual Administrator of the J2EE data supplier or wait for the next scheduled update to get the system in the target SLD

    Best wishes

    Stuart

    Add comment
    10|10000 characters needed characters exceeded