Skip to Content

Issue Installing ABAP AS 751 SP02 on Linux

I'm trying to install ABAP AS 7.51 SP02 according to Blog Post the only difference is im using VMware Pro instead of Virtual Box, I've installed openSUSE Leap 42.3 however im getting the following error:

This is by using the command ./install.sh -g

From the blog the Linux version should be ok unless im missing something.

Here is the linux version:

Could anyone please advice?

Thanks.

error.jpg (68.8 kB)
suse-version.jpg (43.0 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • Best Answer
    Apr 10 at 03:28 AM

    Well, I have an update.

    I managed to install SAP.

    Here is some more detail:

    I decided to start from zero, but instead of using OpenSUSE Leap 42.3, I used OpenSUSE Leap 15.0

    I went through the install which is similar but not quite the same, and proceeded to install SAP doing what your tutorial instructed.

    I got a warning telling me the OS was not supported but it gave me the option to continue anyway so i did.

    I also got a warning about the librearies libaio / libaio1 not being found, which was weird because it was installed... it was just a lower version, and since it gave me option to keep going ignoring the warning i did.

    Lastly I started the install executing install.sh and also got the error about the DNS, at this point i was not very hopefull that it would end well..., however against all odds it did. And it installed correctly.

    So, I have no idea why it failed with openSUSE 42.3, I checked the ISO image checksum and doesnt seem to be corrupted, and I installed it several times (using new VMs) always ending with errors.

    So hopefully this will be useful for anyone else.

    Thank you for your time Julie Plummer

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 07 at 11:53 AM

    Hi Matias,

    Please don't use SWPM with the dev. edition. Otherwise, VMWare + 42.3 should work.

    I blogged about VMWare + 42.3 plus the new version, AS ABAP 752 here : Installing AS ABAP 7.52 dev edition on VMWare and Linux

    Unless you have any specific reason to install 7.51, could you please try the new version + that blog?
    HTH, Julie.

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Julie,

      Thank you for your reply.

      I've tried again with a 7.52 SP01. By reading your link, it mentions SAP 7.52 however the links go to 7.51 SP02, i havent used this version i already had a 7.52 SP01 downloaded.

      I started everything from zero, installed linux but when installing SAP i got this error.

      I think interactive mode is with the SWPM thing you told me not to use right? (I Might be mistaken though, im not expert im just trying to install to practice some abap).

      Thank you.

      error.jpg (262.9 kB)
  • Jan 28 at 01:11 PM

    Hi Matias,

    Let me make sure I understand you correctly: You already have a 7.52 system (whether purchased or developer edition), but want to test a 7.51. Is this correct?

    (I have changed the wrong link btw - I am sorry about that. Thanks for pointing it out.)

    So your problem is only with 7.51.

    If so, then the license has expired. You need to follow the procedure here: ASE License Blog .

    HTH,

    Julie.

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Julie,

      Sorry my reply was a bit confusing, I've tried with both 7.51 and 7.52 (Developer Edition) and im getting error with both.

      The error I'm getting in my previous reply its in 7.52.

      Thank you.

      Edit: Spelling.

  • Mar 20 at 01:11 PM

    Hi Matias,

    Could you please check the log files : tmp/sapinst*log

    Please provide the errors in these log files. Please do not provide the whole file!

    I cannot promise, but we will look at these.

    Best wishes,
    Julie.

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 28 at 01:00 PM

    Hi Matias,

    I googled "SAP ABAP install Unable to determine parameter "DNS domain name" " and found this:

    https://answers.sap.com/questions/623312/netweaver-751-installation-error-unable-to-determi.html

    It includes these tips:

    • I install Ubuntu Server 18.04 without a graphical interface and configured it to use a static IP address. [or in our case "openSUSE 42.3]
    • I also installed the package 'resolvconf' to add my gateway as a DNS.
    • Finally I changed my router settings and gave the device a new hostname: dummy.nodomain.

    Also I have noticed an issue with DHCP: Make sure you are not using DHCP: In YaST > System > Network Settings, Set Hostname via DHCP = No:

    (see AS ABAP FAQs - search for DHCP).

    Do any of these help?
    JUlie.

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 28 at 01:01 PM

    PS thanks for submitting the log files - definitely helps.

    Julie.

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Julie,

      Thanks for your reply.

      I've tried your suggestions however doesnt seem to work.

      The IP address is static.

      package 'resolvconf' doesnt seem to exists.

      When trying "sudo apt-get install resolvconf" i get an error saying:

      "Loading repository data... Reading installed packages... 'resolvconf' not found in package names. Trying capabilities. No provider of 'resolvconf' found. Resolving package dependencies... Nothing to do."

      I've also set Set hostname via DHCP to No.

      Thank you.

  • Apr 10 at 09:45 AM

    Hi Matias,

    Very glad to hear it. Thanks for letting me know.

    Hope you enjoy it, now it works!

    Best wishes Julie.

    Add comment
    10|10000 characters needed characters exceeded