Skip to Content
avatar image
Former Member

Remove Multi columns in Detail Section

I'm converting reports from Crystal 8.5 to Crystal 2008. My old report has a detail section with multiple columns, and I want to remove this formatting. The check box in the section format window is grey and can't be changed. What is the magic combination to get the detail section back to no columns?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Jun 06, 2010 at 05:40 AM

    I came across a solution for this problem on Experts Exchange. It's not quite the same problem but the "Format with Multiple Columns" checkbox is greyed out.

    [Crystal Report Labels Print in Single Column instead of 2|http://www.experts-exchange.com/Programming/Languages/.NET/Visual_Studio_.NET_2005/Q_22834531.html]

    The accepted answer was to make sure that there was a printer set for the report. If the no printer option is set for the report then the "Format with Multiple Columns" option is greyed out. Not sure if this will solve everyone's prolbems or not but it's worth a try.

    For the record I can't reproduce this problem with a report created in CR2008, whether I have a printer set for the report or not set doesn't seem to grey out the checkbox. So take this solution from 2007 with a grain of salt.

    Marshall

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 31, 2010 at 08:47 PM

    Check to make sure that the Lock Format & Lock Size/Position aren't turned on. Both are on the Formatting toolbar atthe top of your screen.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Do you really have 30 group header 3 formats???!!!! Maybe you've hit some limit! (Just kidding!)

      This is a WAG, but is there anything in the Layout tab that might be preventing it? (I just checked what's on that tab and didn't see anything obvious, but...) Maybe try setting the measurements all to zero, and un-check the multiple columns for groups if it's checked.

      HTH,

      Carl

  • avatar image
    Former Member
    Apr 01, 2010 at 03:07 PM

    Unfortunately, I only have 1 details section. In fact, there's no data in that section at all. I'm baffled, so any other suggestions are welcomed! Actually, I've tried changing the size of the columns and rows to see if that would work, but it didn't.

    Edited by: Graham Consulting on Apr 1, 2010 5:07 PM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 06, 2010 at 10:09 PM

    Hi,

    I have a similar problem as follows:

    I am trying to modify a report that was created by Business Vision (using Crystal Reports 10) to print a label from within Business Vision. It was configured to print labels 3 across and 5 down on an 8.5x11" page of labels. I am trying to change the format to single column for a thermal printer. Same problems as you stated above. I can't uncheck the "format with multiple columns" check box. It is greyed out.

    It appears that this report was created with the Label creation Wizard. I have tried to create a report using this wizard and the same thing happens. Greyed out "format with multiple columns" check box.

    Crystal Reports Experts: There has to be a way to change this formatting option. To re-write the complete report with all the selection formulas, parameters etc would take too long.

    I'm hoping that some experts from Crystal Reports are monitoring this forum and will be able to offer a solution.

    Thanks in advance

    Helmut K.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I'm struggling with the same problem, only I'm currently working with a report in version 8.5. The report was originally designed years ago using the Label wizard, but now the client wants to change it to a regular report.

      I decided to "peek under the hood" and this is what I found:

      The Crystal Report Object has a property "Kind" which will have a value corresponding to the application constant CRReportKind. The possible values are these: 1 (crColumnarReport), 2 (crLabelReport), or 3 (crMulColumnReport). Versions 8.5 and 10 are the same. I'm thinking that this property is what's preventing us from getting to that grayed-out checkbox. However, it is a read-only property, meaning, obviously, that you can't change it.

      The report I'm working with is a 2 (crLabelReport). This is the VB6 code I used to find that:

      Dim reportname As String
      Dim oApp As CRAXDRT.Application
      Dim oKind As CRAXDRT.CRReportKind
      Dim oRpt As CRAXDRT.Report
      Dim oSection As CRAXDRT.Section
      
      Set oApp = CreateObject("CrystalRuntime.Application")
          
      reportname = "(put the complete path and filename of the report here)"
      
      Set oRpt = oApp.OpenReport(reportname, 1)
      
      Debug.Print oRpt.Kind
      
      Set oRpt = Nothing
      Set oApp = Nothing

      It doesn't look promising. You will probably have to redo the report, or, it may be possible to recreate the report in VB only setting the Kind property to 1. If someone else can verify that this is doable, it may be the best solution.

      Edited by: marykDBA on Jun 4, 2010 10:59 PM

      Edited by: marykDBA on Jun 4, 2010 11:01 PM

  • Jul 24, 2016 at 11:42 PM

    I ran into this issue after using the "Mailing label report wizard" feature.  I used it for dual column Avery style label printing but when I tried to convert it to a Zebra type single page layout I had to recreate the layout for best results.

    Add comment
    10|10000 characters needed characters exceeded