Skip to Content
Mar 30, 2010 at 10:33 AM

GET_V Method is not called for custom field



We are using CRM 7.0

I have enhanced component BT120H_CPL and added custom fields into view Details with AET. I am trying to implement search help which depends on another field. I have created V-GETTER for my field and tried to implement search help in this method. However, this method is not called in the program scope.

I have debugged the application and result is :

V_GETTER method GET_V_ZZAFLD00000D is created in class ZL_BT120H_C_DETAILS_CN00. It should be called from GET_V_S_EXT method but this method is called in class CL_BT120H_C_DETAILS_CN00 and exception occurs since GET_V_ZZAFLD00000D doesnu2019t exist in class CL_BT120H_C_DETAILS_CN00.

I tried similar scenario : add search help to existing field of another component. However I couldnu2019t able to run GET_V method again.

( It works when I write search help id in the AET but in this way I cannot pass import parameter to it )

Is there anything I am missing ? Thanks in advance for helps.