Skip to Content
avatar image
Former Member

Unable to find Cube / Query in Catalog (Designer)

Hello,

Our current environment consists of BW Queries which are access by BO Universes. When creating a Universe we were able to see all queries but since we did some changes to the MP and cubes we don't see the queries anymore from BO Side.

Also the current reports fail with an error "Unable to find Cube <QueryName> in catalog".

The queries used in the universes are still visible and accessible in BEx Analyzer.

What I tried so far (with a super user) is:

1. Generate query again -> no change

2. Save the query again -> no change

3. Remove the flag u201CAllow external Access to this queryu201D, save query and flag the option again -> no change

4. Activate the MultiProvider again -> no change

5. Copy the query to another query u2013

-> New query is accessible. This means the MP and cubes are not the reason. It seems like the query is gone in an inactive modeu2026

6. Used BAPI BAPI_MDPROVIDER_GET_CUBES to get the list of accessible queries.

-> I see the same list as in BO. Most queries are missing. The ones that are in the list disappear whenever we try to access these queries from BO.

Did anyone encounter the same issue and was able to solve it?

Environment: SAP BI 7.1 EHP1 SP5, BO XI 3.1 SP2(1.7).

Thanks in advance.

Manu

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 26, 2010 at 10:55 PM

    Hi Manu,

    your are talking about universe designer here - right?

    We have a similar behaviour however need to investigate further and sort out proper workflow and evidence.

    Would you be able to build a report with Crystal reports 2008 on top of one of the queries directly?

    I would not really be surprised when you would not be able to get the queries in the CR designer list as well !!!

    This is actually another painpoint for us as well.

    Let me know

    Holger

    Edited by: Holger Brasch on Mar 26, 2010 11:58 PM

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Manu,

      your are talking about universe designer here - right?

      We have the same behaviour currently in Crystal 2008 designer and universe designer.

      In both we can see the same but not the complete list of queries.

      We made sure the "allow external access" option is set in BEX.

      We resolved both issues with same root cause : adjust Query properties -> Req. status -> ...

      Pls refer to thread Unable to find BW Query while creating connection with universe designer as well - thanks Ingo !

      - logon to the SAP system

      - start transaction RSRT

      - enter the technical name of the BW query in the syntax CUBE/QUERY

      - click Properties

      - set the second item called Req.Status.

      - set that one to 0

      Let us know if this helped !

      Holger

      Edited by: Holger Brasch on Mar 26, 2010 11:58 PM

  • Mar 26, 2010 at 04:39 PM

    Hi,

    I would suggest you trace the creation process for the Universe and post the logfiles on a location where people can download it.

    Tracing:

    Unix : Note 1235111

    Windows : Note 1260004

    regards

    Ingo

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 29, 2010 at 02:57 PM

    Hi Olger,

    Thanks for your help. This was indeed the problem.

    In the meanwhile I discovered the same as you did.

    What I did to find the cause I debugged the function module BAPI_MDPROVIDER_GET_CUBES which gets the list of cubes available for external use. This way I discovered that (as you did) the property Data integrity of the query caused the problem.

    When the value is equal to 7 the abap program exits (code commented by SAP programmer as "dirty read to infinity"). Apparently the code for this value has not been implemented or is not available for external use yet.

    The query gets this property from the MultiProvider. What happened is that in the past all Multiproviders created had this property by default equal to 0. Suddenly this default changed to 7 (after installation of SP5 or a patch?). But changing this value back to 0 in the MP is not enough. You have to regenerate the query after the changes (RSRT).

    I've assigned you the points anyway (as your help would have solved the problem as well).

    Thanks again for your help.

    Kind regards,

    Manu Dekeuleneer

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Ingo Hilgefort

      I got this error now. I followed the notes here and understood that I have to change the Req. Status = 0 from 7. However per Ingo's instructions, I read SAP note 1408037 which says to install SP6 on top of SAP BW 7.01(ehp 1). We are already on SP6, but still get the same error.

      I wonder why though? Our reports are now moved into Q system, and integration testing is going on world-wide, and some of the reports are throwing up this error. Surprisngly the report runs OK in Dev, which is also on SP6!!!.

      For now, I am going to change multi-provider settings in Dev and take it to Q. I understand that I have to regenerate BEx query after that change. Will do, but my question is that why do we get error, even though we are on SP6 already??