Skip to Content
Former Member
Mar 25, 2010 at 09:01 AM

Start BPM process from ABAP report. Need some investigations.


Hi there!

I have to start a BPM process from ABAP report. I found an article and have done everything it describes but the process doesn't start.

What I've done:

1) Created a service proxy in SE80.

2) Created a logical port in SOAMANAGER.

3) Write a code to start a WebService in ABAP Report.

But when I start a program nothing happens, no errors.

What analysis I did:

1) See logs and traces in SOAMANAGER - there is nothing appears after I start the report.

2) Tried to test connection to my WebService in SM59 - the connection works, but it use a POST method instead of GET:

Error: - Expected request method POST. Found GET.

But I think it is OK and from the report it use a right method.

3) Tried to delete a logical port - the error of communication problem appears. So it means that all settings are right.

4) No logs in NWA logs

My thoughts - if there is not any errors and no result, it can be because the user authorization. E.g. it tried to start a process by a user who doesn't have SAP_BPM_SuperAdmin role. But I can't find a way how to check what really happens. So I want to ask for a help, colleagues:).