Skip to Content
avatar image
Former Member

Can not start/access MII 12.1

Hi,

I installed MII 12.1 SP 05 on a newly installed NW CE 7.1 EHP1 SP 04.

The installation of MII proceeded without any errors.

But when I now try to access the MII website via http://host:port/XMII the following error is shown in the browser:

Error: Application cannot be started!

Troubleshooting Guide https://sdn.sap.com/irj/sdn/wiki?path=/display/jsts/home

Details: "The WebApplicationException log ID is [000C2984894500300000000100000E98]."

So I have checked the logs of NW and found the following exception (I didn't post all details of the stack trace because I can not format the post in a readable kind then):

Web application [XMII] cannot be started. The error is: com.sap.engine.services.deploy.container.DeploymentException: Cannot activate endpoint for message-driven bean sap.com/xappsxmiiearxml|sap.comxappsxmii~ejb.jarxml|JRARFCListener

...

Caused by: com.sap.engine.services.ejb3.container.ActionException: Cannot activate endpoint for message-driven bean sap.com/xappsxmiiearxml|sap.comxappsxmii~ejb.jarxml|JRARFCListener

...

Caused by: javax.resource.ResourceException: None of the existing ResourceAdapter-s has been activated successfully. For more details see connector logs.

...

Caused by: javax.resource.NotSupportedException: reject registering function having binding XMII at RA with BindingKey=XMIIIDOC and ProgramId=null

Can anybody help me and tell me where to find the connector logs or how to solve this issue?

Regards

Timo

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 18, 2010 at 12:39 PM

    Hi Timo.

    We have had some problems with MII installation and I have seen something similar, and i suspect that the SAP Java version have something to do with it.

    I would recomend you to install it on Netweaver SPS3 and only that version as this combination is the best (I think that version comes with Java version 36).

    BR

    Poul.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      the problem is, that I alreay upgraded the NW 7.1 to SP 04. Don't know how (and if it's even possible) to downgrade it to the SP 03.

      How can I determine the Java version used by NW?

      Regards Timo

  • avatar image
    Former Member
    Mar 26, 2010 at 07:43 PM

    Hi.

    You should be able to determine the java version by looking at this path

    ?:\usr\sap\<SID>\SYS\exe\jvm\NTAMD64

    BR

    Poul.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 14, 2010 at 09:29 AM

    Hi,

    I installed the latest service pack of MII 12.1 today (the one from 7th of april). Now the error message doesn't occur anymore and I can start and use MII 12.1 in combination with NW 7.11 SP 04 without any problems.

    Thanks for your help!

    Regards Timo

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 14, 2010 at 09:32 AM

    Hi.

    Nice to hear, I will try that version out shortly.

    BR

    Poul

    Add comment
    10|10000 characters needed characters exceeded