Skip to Content
avatar image
Former Member

Initial Setup of functional unit ADS error in Netweaver CE 7.1 EHP1

Nice to meet you everyone.

After I installed Netweaver CE 7.1 EHP1,I'm executing Post Installation Step.

When I executing the Initial Setup of functional unit ADS,some strange happen.

In the Step 23 of 23 : Create logical port "ConfigPort_Document"

There is a error below like.

======================================================================================================

java.lang.NoSuchMethodError: com.sap.engine.services.webservices.espbase.configuration.BindingData.setConfigurationType(I)V

at com.sap.esi.esp.lib.mm.config.impl.ConfigurationRootImpl.preserveBindingDatas(ConfigurationRootImpl.java:761)

at com.sap.esi.esp.lib.mm.config.impl.ConfigurationRootImpl.updateService(ConfigurationRootImpl.java:507)

at com.sap.esi.esp.service.server.ESPServiceInterfaceAbstract.updateSingleServiceLocal(ESPServiceInterfaceAbstract.java:1393)

at com.sap.esi.esp.service.server.ESPServiceInterfaceImpl.updateRuntimeConfiguration(ESPServiceInterfaceImpl.java:1418)

at com.sap.esi.esp.service.server.ESPServiceInterfaceImpl.updateRuntimeConfiguration(ESPServiceInterfaceImpl.java:1283)

at com.sap.esi.esp.service.server.ESPServiceInterfaceImpl.updateRuntimeConfiguration(ESPServiceInterfaceImpl.java:1271)

at com.sap.ctc.util.additional.services.as.WebServiceClientConfiguration.createLogicalPort(WebServiceClientConfiguration.java:123)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)

at com.sap.tc.lm.ctc.provider.javaServiceProvider.JavaMethodExecuter.invoke(JavaMethodExecuter.java:247)

at com.sap.tc.lm.ctc.provider.javaServiceProvider.JavaServiceExecuter.executeService(JavaServiceExecuter.java:98)

at com.sap.tc.lm.ctc.cul.broker.BrokerServiceExecuter.executeService(BrokerServiceExecuter.java:54)

at com.sap.tc.lm.ctc.cul.serviceimpl.executor.CULServiceExecutor.executeService(CULServiceExecutor.java:51)

at com.sap.tc.lm.ctc.cul.serviceimpl.process.InvokeServiceControllerDefault.execute(InvokeServiceControllerDefault.java:166)

at com.sap.tc.lm.ctc.metamodel.process.controller.ProcessControllerImpl.execute(ProcessControllerImpl.java:275)

at com.sap.tc.lm.ctc.metamodel.process.controller.ProcessControllerImpl.execute(ProcessControllerImpl.java:275)

at com.sap.tc.lm.ctc.metamodel.process.controller.ProcessControllerImpl.execute(ProcessControllerImpl.java:275)

at com.sap.tc.lm.ctc.metamodel.process.controller.ProcessExecuter.run(ProcessExecuter.java:158)

=====================================================================================================

Is there anyone who can help me?

Regards...

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Mar 15, 2010 at 09:07 PM

    Hi Lee,

    I think I know how to solve this. I have just solved a similar problem with my PI 7.1 EHP1. Deployment in JSPM of various software components all failed like this example:

    JSPM log:

    ...

    Deploy status is 'Aborted'

    Client path '
    pi71\sapmnt\trans\EPS\in\SAPXIAF04_7-20002649.SCA'

    Description:'1. ERROR CODE DPL.DS.5089 Exception during generating components of sap.com/com.sap.aii.af.app application in webservices_container container.

    -> com.sap.engine.services.webservices.espbase.configuration.BindingData.getConfigurationType()I'.

    ...

    Default Trace:

    ...

    Caused by: java.lang.NoSuchMethodError: com.sap.engine.services.webservices.espbase.configuration.BindingData.getConfigurationType()I

    at com.sap.engine.services.webservices.server.deploy.WSBaseAbstractDProcess.getBindingDataId

    ...

    After that most of the browser based admin apps, such as NetWeaver Administrator ( /nwa ), would refuse to start.

    But finally after several tests, searching on SDN+SMP and restore to backup version I found the solution in [SAP Note 1328776|http://service.sap.com/sap/support/notes/1328776] which describes a similar problem: Update to the newest version of ENGINEAPI 7.11. Today this is ENGINEAPI04P_4-20002603.SCA.

    You may also want to make sure that you are running the newest version of the Configuration Wizard, so you should check/update LMTOOLS, LMCTC and LMCFG*, currently LMTOOLS04P_3-20002705.SCA, LMCTC04P_1-20002694.SCA and LMCFG04P_4-20002729.SCA.

    I hope this proves to be useful.

    regards

    Mauri

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear Mauri...

      Thanks for your sincere response.

      As you guide I updated ENGINAPI7.11 to the latest version.(ENGINEAPI04P_4-20002603.SCA)

      It was relased on 24.02.2010.

      And finally the problem was solved.

      I finally executed the step Initial setup of functional unit ADS successfully.

      Thanks one more time.

      And Is there any method which I can test ADS service working correctly?

      Regards..

      Jung Soo Lee

      Edited by: Lee JungSoo on Mar 16, 2010 1:54 AM

  • Mar 16, 2010 at 08:25 AM

    Yes, you can go to tx SE38 in your backend and check the reports called FP_* (mostly has TEST in the program name). You can use these to do the test. For example FP_TEST_00 is the best one to start with. Otto

    Add comment
    10|10000 characters needed characters exceeded