Skip to Content
author's profile photo
Former Member

CR XI R2: Salesforce 3.0 driver on Windows 7 64-bit?

Hello. I have CR XI r2 SP6 with the Salesforce 3.0 driver running on Windows 7 64-bit. When I try to connect to Salesforce, I get an error message "Invalid argument provided. java server setup failure. Please verify the PATH etc etc etc. Please verify you are using JDK 1.4"

Is there a newer version of the Salesforce driver? Anyone know if these paths can be pointed to a newer version of the JDK?

Thanks

David

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Posted on Mar 12, 2010 at 02:43 PM

    Hi David,

    Crystal does have a dependency on the JDK 1.4 and it should have installed when you installed Crystal Reports.

    You did not say if you have any JDK's installed and what that version is?

    Have a look at this link also and possibly post your question in that forum too:

    how-to-enable-support-for-salesforcecom-api-v13-in

    Thank you

    Don

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Don,

      I've tried all the other solutions in the link and still have the same issue. Is there anything specific to 64-bit?

      Crystal is using Java 1.4 from it's own install.

  • author's profile photo
    Former Member
    Posted on May 03, 2011 at 06:06 PM

    David,

    Did you ever get a solution. I'm having exactly the same issue CR XI R2, Salesforce 3.0, on Wiindows 7 64-bit. I've applied SP5 and tried compatibility mode but no luck getting a connection.

    Add comment
    10|10000 characters needed characters exceeded