Skip to Content
0
Dec 18, 2018 at 11:44 AM

Error in Webi Rich client, in BI launchpad everything is working fine

380 Views Last edit Dec 18, 2018 at 11:46 AM 3 rev

Hi all,

We experience an error when we try to refresh a report in rich client or try to open a bex query in the rich client.
In the BI launchpad everything is working fine.

In the rich client we can connect to the system and open reports, but the error appears when we refresh the data or try to create a new report.
We have SSO BW logon activiated.

When refreshing we get the error: "Failed to Connect to OLAP source"

When trying to opening a bex query after clicking on the olap connection we get following error:

[[error.openSapBwBrowsingSessionFailed] 0] <<?xml version="1.0" encoding="UTF-8" standalone="yes"?><ConnectionString>

<Properties>

<Password />

<Initial Catalog />

<SaveLanguage>true</SaveLanguage>

<TargetProvider>SAPNETWEAVER7X</TargetProvider>

<Cube Type>Unknown</Cube Type>

<Data Source>*****</Data Source>

<User ID />

<NetworkLayer>SAPBW_BICS</NetworkLayer>

<MaxParallelQueries>4</MaxParallelQueries>

<Authentication Mode>2</Authentication Mode>

<Initial Cube />

<Language>en_US</Language>

</Properties>

<ExtendedProperties>

<SapLoginMode>0</SapLoginMode>

<JCO_CLIENT>001</JCO_CLIENT>

<JCO_R3NAME>BIP</JCO_R3NAME>

<JCO_LANG>EN</JCO_LANG>

<JCO_ASHOST>*******</JCO_ASHOST>

<JCO_SYSNR>00</JCO_SYSNR>

<ManagedMode>CLIENT</ManagedMode>

</ExtendedProperties>

</ConnectionString>>,<java.lang.NoClassDefFoundError: com/crystaldecisions/sdk/plugin/authentication/sap/internal/SAPR3GlobalState$CannotRetrieveException>

I don't see what the cause or solution could be.

BO Version server: 4.2 SP6 patch 2

Client tools: 4.2 SP6

Thanks a lot.