Skip to Content

Crystal Reports slow to move from pending to running

BI Platform 4.2.4

We sometimes have Crystal Reports that sit in a pending state for a quite awhile even though there are no jobs actively running. They do eventually run successfully. What would be the cause of such a delay?

Could it be Idle Job Timeout settings in the various Crystal Servers (Processing, RAS, Cache)?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Dec 18, 2018 at 02:37 PM

    Crystal for Enterprise or "classic" Crystal?

    For classic Crystal, I believe that all of the processing for a schedule still happens in the job server - unlike Webi where it gets passed to the processing server.

    Do your reports have saved data in them? If so, the delay might be caused while the report is being opened (reports with data take longer to open) or while the data is removed from it. And if I'm wrong about this, I'm sure someone else will chime in here...

    -Dell

    Add comment
    10|10000 characters needed characters exceeded

    • That would definitely cause delays if there are lots of reports that are scheduled at the same time. However, it can be challenging to find the "sweet spot" for number of concurrent jobs that won't overload your server resources. The default value is 5, I wouldn't increase it to more than 15, possibly less if your server doesn't have a lot of RAM or disk space. The disk space is because Crystal can do a lot of swapping to disk if a report is large or if it has to join or filter tables in memory instead of passing the join or filter to the database.

      -Dell

  • Dec 20, 2018 at 05:28 PM

    Hi Michael,

    Iam having a similar issue-but weirdly it goes away on its own.

    How /where did you change the setting?

    Thanks

    Sandy

    Add comment
    10|10000 characters needed characters exceeded

    • I'm not sure if it's the solution but in the CMC >> Servers >> Adaptive Job Server properties there are a number of configurable settings for scheduling services. You can set the Maximum Number of Concurrent Jobs for each of the services. Your own usage patterns/needs and system resources would dictate how high or low you set the number of jobs. In my situation I have two servers clustered together but one had CR set to 15 concurrent and the other was only 2. I THINK that contributed to the unpredictable behavior/delays.