Skip to Content

SMT mapping issue after upgrade

Hi Experts,

Facing SMT mapping issue after up gradation for custom attributes which are available in standard entity "Material " and these attributes not considering in mapping reports(showing mapping for these attributes in smt config ). Tried to fix this issue by doing changes in SMT & data model(removed and adding attributes) but issue not resolved[MDG-M 8]. Please let me know any suggestions on this issue.

Regards,

SMB

Add a comment
10|10000 characters needed characters exceeded

Related questions

8 Answers

  • Posted on Jan 04, 2019 at 10:34 AM

    Hello Shaik,

    QMPUR is a std attrivute added from MDG version 7 in Entity MARAQMTNG.

    So if you are now upgrading to MDG 8 you would have this too.

    I understand that you were earlier in a relaese lower than MDG 7 and had thus added this as a customatrribute in entity MATERIAL.

    But why do you want to continue using your Custom attribute now? Now you have upgraded & had a standard SAP attribute.


    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 20, 2019 at 06:17 AM

    Dear All,

    Thank you so much for all the support, actually its a standard bug and fixed with snote.

    Regards,

    Mahaboob Basha

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 17, 2018 at 03:18 PM

    Please check

    2709191 - SMT Mapping issue for Material

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 18, 2018 at 07:38 PM

    Hi Prem,

    Thanks for sharing the information & help.

    I checked the mentioned snote but unfortunately it will not support my issue as MDG framework not considering custom attributes of a standard entity(enhance). Kindly let me know any other suggestion.

    Regards,

    SMB

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 19, 2018 at 09:19 AM

    Hi Shaik,

    Please check this SMT Mapping after Upgrade

    Thanks,

    Mahesh


    smt-switch.png (93.1 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 20, 2018 at 08:52 AM

    Hi Experts,

    Any suggestions please.

    Regards,

    SMB

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 31, 2018 at 06:37 AM

    Hi Experts,

    Any suggestion on this issue as I raised sap incident but days are going on but no solution.... any other alternative solution to replicate the value of QMPUR which is available in standard structure MDG_BS_MAT_MARA. After upgrade SMT mapping not supporting for custom attributes which were added in standard entity MATERIAL.(QMPUR is one the attribute), these attributes mapped with standard attributes which were available in standard strucuture.

    Appreciated any support or suggestion.

    Regards,

    SMB

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 20, 2019 at 05:30 AM

    Hi Shaik,

    if your issue is still not resolved, can you please check the below mention settings:

    Can you please check and compare the version of SMT mapping before upgrade(you will find this in non upgraded system ) and after upgrade.

    Go TO SM34->enter the view VC_SMT_TRANSF->select the mapping step for which you are getting the issue.

    If this version is less in upgraded system , please increase this version by changing the description of mapping step and save. Each time you will change the description it will increase the version. Keep changing the description till the time it will reach to one higher than the before upgrade version.

    Regards,

    Bipin Kumar Singh


    smt1.jpg (55.3 kB)
    smt2.jpg (63.7 kB)
    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.