Skip to Content
0
Former Member
Feb 26, 2010 at 05:13 PM

Can't delete dynamic parameter after deleting command

26 Views

I have a report that I inherited. It used commands instead of stored procedures to retrieve the data. I needed the data in a stored procedure, so I went through and systematically switched everything over to the stored procedure fields. When I thought I had it all moved over to the new fields, I deleted the commands. I then went to publish the report using the Publishing Wizard. It told me that I had unused parameters. When I went back to check the report, I found 2 unused parameters. I tried to delete or edit them and I can't do either function (I click the delete or edit option and nothing happens). I tried adding the command back in, but I still couldn't delete them. The parameters are definitely not being used anywhere in the report because: 1) I have checked everywhere and 2) they do not display the usual check mark when a field is being used.

This is an extremely complex report, and it is database intensive on a production server (I've brought the system and its users to its knees by attempting to run the report. It is designed to run at 5am and it still takes an hour). So, I'd really rather not recreate the report.

Does anyone have any ideas?

I saw someone else had this issue in April, 2007 (can't-delete-a-dynamic-parameter-from-report), but it never got resolved (I imagine the user recreated the report).

Thanks.

Lisa