Skip to Content

HANA express on Virtual Machine, web ide - "Uh oh - something went wrong".

Nov 28, 2016 at 05:21 AM


avatar image

Yesterday my HANA Express was running nicely on my VM (through VM Workstation on my PC), and I was working through the Software Development on SAP HANA (Update Q4/2016) course. When I'd finished what I was doing, I paused my VM.

Today, I restarted the VM.

When I went to https://hxehost:53075 in my browser I got the very useful and informative message "Uh oh - something went wrong".

In my HANA Express VM, logged in as hxeadm, I did as Thomas Jung has suggested and restarted di-core xs rs di-core

Same issue.

So, I restarted HANA

HDB stop
HDB start

I typed xs apps and got the messages:

FAILED: Could not decode access token: REST request POST to url 'https://hxehost:30032/uaa-security/check_token' had response code 500 (Operation failed due to unexpected server error) with error message: '{}' 

So I tried xs login with xs_admin and url https://hxehost:30030 (with -skip-ssl-validation)

I'm getting the message UAA at https://hxehost:30032/uaa-security is not up

This answer is not relevant as I have not changed the keys.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Denys van Kempen
Nov 28, 2016 at 01:48 PM

Hi Matthew,

Is HANA up and running normally? You can check this with either studio (on your host) or cockpit (on the guest).

When you pause the VM, you crash the database. So it needs to recover, which will take some time. If you stop and start during this process, it will take some longer.

There is a video on this topic (how to stop and start HANA Express);

Complete HANA Express playlist:



Show 1 Share
10 |10000 characters needed characters left characters exceeded

Ah - I naively assumed that pause a VM meant it just paused. But since, as you say, it crashes the database, it all makes sense.

I did observe that I have no problems if I shutdown HANA first.

Vahid Sadiri Javadi Dec 09, 2017 at 07:04 PM

I just add this to Denys comment:

I got this error as well: "Uh oh - something went wrong"

You can solve it easily by editing your the /etc/hosts File, as it is described in detail in "Getting Started with SAP HANA 2.0, express edition" PDF File.

10 |10000 characters needed characters left characters exceeded