Skip to Content
0
Former Member
Feb 26, 2010 at 10:33 AM

Problem in Making connection of screen fields with structure

31 Views

Dear experts,

I hv created screen for ekpo table fields. And I hv created a structure of required field from ekko.

I m getting no erro msg. But hen I execute the program with Tcode, it display the screen but does't display the info.

I hv debugged it and found that nothing is coming in the internal table.

I hv Written folloing code for my module pool program ( I hv used SE80 for this).

 
PROGRAM  ZDEMO_DYNPRO_DICTIONARY1.

tables :zekko.

data : EXIT(1) TYPE C.
data : wa_ekko like ekko.

start-of-selection.

call screen 100.

*&---------------------------------------------------------------------*
*&      Module  INIT_SCREEN_100  OUTPUT
*&---------------------------------------------------------------------*
*       text
*----------------------------------------------------------------------*
MODULE INIT_SCREEN_100 OUTPUT.

  MOVE-CORRESPONDING WA_EKKO TO ZEKKO.
  CLEAR WA_EKKO.

ENDMODULE.                 " INIT_SCREEN_100  OUTPUT

*&---------------------------------------------------------------------*
*&      Module  USER_COMMAND_0100  INPUT
*&---------------------------------------------------------------------*
*       text
*----------------------------------------------------------------------*
MODULE USER_COMMAND_0100 INPUT.

*
*IF EXIT NE SPACE.
*  LEAVE SCREEN.
*ENDIF.

MOVE-CORRESPONDING ZEKKO TO WA_EKKO.

SELECT SINGLE
    EBELN BUKRS BSART LOEKZ AEDAT ERNAM LIFNR
    INTO CORRESPONDING FIELDS OF WA_EKKO
    FROM EKKO
    WHERE EBELN eq WA_EKKO-EBELN.

ENDMODULE.                 " USER_COMMAND_0100  INPUT

can anyone help me with this.

Maverick

Edited by: Maverick44 on Feb 26, 2010 11:43 AM