Skip to Content
author's profile photo Former Member
Former Member

SAP EHP Installer not working

Hi

I've installed EHP installer, but when I go in through the web gui <host>4239, I manage to get to the initial page. When clicking on the EHP Installer link, it opens up Java 6 and I then get the following message:

Unable to launch application:

com.sun.deploy.net.FailedDownloadException: Unable to load resource: http://I5SAP:4239/sdtdsu.jnlp

at com.sun.deploy.net.DownloadEngine.actionDownload(Unknown Source)

at com.sun.deploy.net.DownloadEngine.getCacheEntry(Unknown Source)

at com.sun.deploy.net.DownloadEngine.getCacheEntry(Unknown Source)

at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(Unknown Source)

at com.sun.deploy.net.DownloadEngine.getResourceCacheEntry(Unknown Source)

at com.sun.deploy.net.DownloadEngine.getResource(Unknown Source)

at com.sun.deploy.net.DownloadEngine.getResource(Unknown Source)

at com.sun.javaws.Launcher.updateFinalLaunchDesc(Unknown Source)

at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)

at com.sun.javaws.Launcher.prepareToLaunch(Unknown Source)

at com.sun.javaws.Launcher.launch(Unknown Source)

at com.sun.javaws.Main.launchApp(Unknown Source)

at com.sun.javaws.Main.continueInSecureThread(Unknown Source)

at com.sun.javaws.Main$1.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Any ideas?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Posted on Feb 25, 2010 at 11:03 PM

    Hi Wouter,

    2 things:

    - SAPEHPI is supprted with Java 5 (1.5) only ! => you should deinstall 6 and install 5

    - it is needed to copy a few directories over to your PC and start it from there ... described in some notes ...

    (the i5 URL is not working ...)

    Regards

    Volker Gueldenpfennig, consolut international ag

    http://www.consolut.net - http://www.4soi.de - http://www.easymarketplace.de

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      OK.. first things first. Thanks for this post it solved my issue too. I had the same issue.

      Now about the issue's solution.. i used /<DVD mount directory>/STARTUP guistart=on to start the SAPEhpi and everything worked fine till the end. No issues.

      And for them who are still looking, If you are using latest SAPEhpi (131 in my case ) you don't need to provide java pf param with STARTUP.

      Thanks

  • Posted on Aug 31, 2011 at 03:23 PM

    Hello all,

    first, about the installed JVM's: You can have installed several Java versions in parallel, e.g. for me as developer, I have 4 different Java versions installed for different development purposes (JDK's 1.3.1, 1.4.2, 1.5 and 1.6). The default Java version is defined by the Windows environment variable JAVA_HOME (in my case it's 1.6). So, there is no need to uninstall any other Java version. If you just have JRE versions (Java Runtime Environments) the last installed version wins when installed with default settings.

    Second, for the SDT GUI as it is used with SAPehpi or similar tools there is a check for outdated Java versions. The GUI requires at least Java version 1.5 or higher on the frontend PC. Doesn't matter if you have a JRE or the full JDK installed and also doesn't matter which Java version you are running on the IBM i machine. This is a PC only problem. Even Java 1.6 (or Java 6, which is just its new name) works fine with the SDT GUI. Nevertheless some problems may occur when launching a JNLP file for the first time via browser.

    About the problem Wouter originally had. I assume the Java 6 was not properly installed or at least its browser plugin needed for the way the SDT GUI is usually called. With the new installation of Java 1.5 this was solved. But the reinstallation of Java 6 would had solved the issue as well.

    Whenever you run into such problems, there are two options. If you want to get it quickly run, just map a network drive for share

    as400hostROOTBIN and navigate to script DSUGui.bat (as pointed out several times in this thread) and start it via double click. The most important thing for this script is a valid environment including the JAVA_HOME variable to find the "java" command. If you want to spend more time on this you should work on this check list:

    • your Java installation on the PC (at least version 1.5)

    • browser settings (LAN zone settings for intranet/internet, browser plugins)

    • network settings (is the IBM i host name known to the network, e.g. with "ping")

    • firewall settings (maybe the load of external Java programs is blocked)

    • ... or ask Google ( I know, can be a mess)

    The mechanism of loading the JNLP file for the GUI is well proved and if it doesn't work usually a setup issue of the PC is the reason.

    Best regards,

    René Lang

    SAP on IBM i Development

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 17, 2011 at 11:02 AM

    In case run SolmanUp tool, when solman upgraded can be helpfull correction Java option. For example in our case:

    "Start" -> "Control Panel" -> "Java" -> "General" -> "Network Settings" -> "Network Proxy Settings"

    set to "Direct connection"

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 29, 2013 at 09:42 AM

    Hi Folks,

    You may even try this.

    Add the host name (FQDN) to the proxy.

    IE -> Tools -> Internet Options -> Connections -> LAN Settings -> Advanced ->

    Make your host entry in the exceptions list

    Eg: *abcdhost*

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.