Skip to Content

HTTP Receive failed: Connect to proxy:8080 failed: NIEHOST_UNKNOWN(-2)

I am trying to create oData service in iwfnd/gw_client but after adding entitysets it is showing error that HTTP receive failed. what should I do. Is this basis issue. If so, where should be the problem? please help.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • May 28 at 08:39 AM

    Hi

    It seems that you do not have a proxy configured properly. You could try and deactivate the proxy settings (untick "Proxy setting is active") in SICF and test if it works without. It worked for me.
    Goto SICF press execute and select Client -> Proxy settings from the menu and untick "Proxy setting is active".

    Regards,

    Caroline

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 14, 2018 at 01:27 PM

    This looks like a BASIS issue, however difficult to judge what is the root cause. There may be a lot of different reason like wrongly configured HTTP server or the host name is incorrect.

    I would recommend to contact with a BASIS Admin in your organization.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 14, 2018 at 09:23 PM

    Hi Preety,

    Well, lets see NIEHOST_UNKNOWN means Network Interface Error Host Unknown...

    That means that the hostname used cannot be resolved.... I would check that the hostname given is correct and available via DNS and or update the hosts file with the IP and hostname.

    Also after checking a few old threads seems like some people suggested that the protocol could be wrong, try with HTTPS instead.

    Regards, JP

    Add comment
    10|10000 characters needed characters exceeded