Skip to Content

Version not editable in assembly after moving SC into new NWDI

Hi Experts,

I do have a strange behaviour after having migrated a SC into another NWDI.

We started development in our local NWDI system (based on Netweaver 7.2) and now moved into the customer NWDI (based on Netweaver 7.5).

To move the SC into the new track we created a normal SCA assembly and exported this from our NWDI system and simply imported the same file into the new dev track in the customer system.

Importing and running through dev and cons stages works perfectly fine. The only issue is, that in assembly stage it is not possible anymore to set the support pack and patch level versions. The version which was imported during check-in is fixed.

Since we want to continue development in the new NWDI system this is a problem for us.

So far I could not find any hint how to fix this issue.

It seems to be related to the fact that the SCA file was imported with the check-in....

Any good ideas what would need to be changed are highly appreciated!

Thanks,

Martin

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Dec 13, 2018 at 07:38 AM

    Hello Martin,

    You can set the SP/patch level as long as you are in the same CMS Domain with the new track, as with the old one. As you imported the SCA into such a track which is in an other NWDI you have the below options to modify the version.

    There are workarounds available:

    1, Create an intermediate (migration) track in the 7.50 NWDI. Then when assembling again in the target (7.50 track) you should be able to change the SP and Patch level. Please find more information about this in the KBA 2423077.

    2,: You could try to implement point 2 of the following SAP Note: 973346.

    Best Regards,

    Viktor

    Add comment
    10|10000 characters needed characters exceeded