Skip to Content
0
Former Member
Feb 24, 2010 at 09:22 AM

IGS Going down in few Seconds

204 Views

Hi,

In on of our system during kernel upgrade to 69 we got an error like dispatcher running but dialogue info unavailable. During the troubleshoot of the problem I got one note sapnote_0000072248 to change the parameter rdisp_elem_per_queue in start profile to the value in instance profile. So when I performed the profile change operation got an IGS error. IGS gone red and not starting, with same dispatcher status. Anyway I have solved the dispatcher problem finally, but IGS is in gray now. During SAP startup it comes to green in one or two seconds goes back to gray. I have tried all the ways through command propt to start but couldn't. When I have checked the IGS RFC connections there are failing showing the problem program IGS.<SID> is not registered. I have tried to register with command rfcexec -D<RFCdestination> its of no result and when I have tried with rfcexec -a -g -x (going in loop or no prompt again) and checked in SMGW then the program getting registered and RFCs are successful, but IGS startup is not successful through cmd and MMC. When ever I manually exit the rfcexec -a -g -x command then again same problem with RFCs and no entry in SMGW.

Please explain whats going on internally why didnt the program getting registered permanently when I execute rfc command.

What is the solution for this problem?

Thanks.