Skip to Content
0

Replace /Removal buttons unavailable in SAP Work Manager 6.3 Meter Management 2.1.

Nov 27, 2016 at 02:27 AM

94

avatar image
Former Member

Hi Experts!

I have an issue with the Meter Replacement process in SAP Work Manager 6.2 with Meter Management 2.0.

We cannot enable the buttons Replace or Removal in a Work order.

1. Transmit a Work Order with an Equipment as a Reference Object to Work Management Mobile.

2. Start Work Order and press Meter button.

3. We can see all the Meter Information, but the action buttons in the Meter view are inactive.

Other Meter Management processes like Meter Disconnection/Reconnection and Meter Installation are working fine.

Only for Meter Replacement and Removal the buttons stay inactive.

The according work order operation has been started and the customizing also seems to be setup correctly. I am using order type "ZSUS" for the meter replacement:

Are there any configuration or pre-requisite in the Work Order to enable this Replace/Removal functionality?

Thank you in advance.

Best regards,

img-7841.jpg (643.7 kB)
replace-note.jpg (136.3 kB)
10 |10000 characters needed characters left characters exceeded

Hi Jose ,

Based on your remark , reference in the Work Order to the app, so the rule couldn't validate Equipment status and that's why buttons never appeared. I will post resolution from the incident.

" The storage location field is always mandatoy for Complex Table ctSerialNumber in a IS-U Device, in class /SMISU/CL_MD_DEVICE_DO, method GET_COMPLEX_TABLE . The Equipment data field in the backend is empty, that's why they did not receive any data."

Thanks

Subash Narayan

SAP Product Support

1
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
avatar image
Former Member Dec 06, 2016 at 05:49 PM
0

Hello Bill,

Thank you for your response.

I wasn't bringing any equipment reference in the Work Order to the app, so the rule couldn't validate Equipment status and that's why buttons never appeared.

I changed Filters for ctEquipment and that's buttons finally showed up.

Best regards and thank you again.


replaceremoval.jpg (42.4 kB)
Share
10 |10000 characters needed characters left characters exceeded
Bill Froelich
Nov 28, 2016 at 03:02 PM
0

I would recommend you look in the Editor to see if there is an enable rule on the associated Replace/Removal action buttons. I suspect there is a condition that is preventing the action from being enabled.

--Bill

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Nov 30, 2016 at 05:08 PM
0

Hi Bill,

Thank you for your answer.

I have reviewed the Enables rules, but I'm not clear about how they work:

EnableMeterReplacement

EnableMeterRemoval

The work order has a Equipment previously installed (the one I need to Replace, or Removal), and the Work Order Status is "STARTED" in Work Manager.

@manju.venkatesha @michael.appleby @mark.pe
Could you please help us? Have you ever seen this issue before?

Thank you in advance.


Share
10 |10000 characters needed characters left characters exceeded
Bill Froelich
Dec 02, 2016 at 01:56 PM
0

Something looks funny about your rules. It looks like there is a problem with the rule structure and/or missing globals. Is this from the out of the box meter management version?

My rules look like the following:


--Bill


Share
10 |10000 characters needed characters left characters exceeded